Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #10252 (closed)

Opened 7 years ago

Closed 6 years ago

Bug: Build issues with 'test' target of OmeroCpp

Reported by: bpindelski Owned by: rleigh
Priority: critical Milestone: OMERO-4.4.9
Component: OmeroCpp Version: 4.4.8
Keywords: n.a. Cc: rleigh, jamoore
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description (last modified by bpindelski)

Testing conducted on Windows 7 Enterprise 64bit edition.
Installed Windows SDK 7.1 and the full .Net Framework 4.0. Invoked

build.bat -f components\tools\OmeroCpp\build.xml test

The compilation failed first, as the Windows 7 SDK Prompt has been started without the '/x86' switch. After that the build failed again, as the 'SConstruct' file has the following line

compiler_env["ARCH"] = (env.is64bit() and "64" or "32")

which sets the 'ARCH' variable to 64 bit, and that could conflict with the SDK setting.

Other possible causes:

  • during build:
    test-compile:
    Building with ICE_HOME=/usr/share/Ice
    Debug setting: True (debug)
    64-Bit build: True (detect)
    
  • 'ARFLAGS': ['/nologo', '/MACHINE:X64'] in scons.log


Error message:

target\omero\api\Exporter.obj : fatal error LNK1112: module machine type 'X86' c
onflicts with target machine type 'x64'
scons: *** [omero_client.dll] Error 1112

BUILD FAILED
C:\dev\openmicroscopy\components\tools\OmeroCpp\build.xml:35: The following erro
r occurred while executing this line:
C:\dev\openmicroscopy\components\antlib\resources\global.xml:498: exec returned:
 2

Total time: 1 minute 8 seconds

C:\dev\openmicroscopy>

Attachments (1)

Screen shot 2013-01-28 at 14.41.01.png (28.2 KB) - added by bpindelski 7 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by bpindelski

  • Description modified (diff)

comment:2 Changed 7 years ago by bpindelski

  • Description modified (diff)

Changed 7 years ago by bpindelski

comment:3 Changed 7 years ago by jmoore

  • Cc jesse.corrington@… added
  • Component changed from Tools to OmeroCpp
  • Priority changed from major to critical

Adding Jesse as a possible discussion point tomorrow while discussing C++. Feel free to change to your trac login when/if you have it.

comment:4 Changed 7 years ago by jmoore

  • Cc jesse@… added; jesse.corrington@… removed

comment:5 Changed 7 years ago by jmoore

  • Cc jesse@… removed
  • Owner set to jcorrington-x

comment:6 Changed 7 years ago by jamoore

Referencing ticket #1835 has changed sprint.

comment:7 Changed 7 years ago by jburel

  • Owner changed from jcorrington-x to rleigh

Removing Jesse as owner. Passing it to Roger, feel free to modify.

comment:8 Changed 6 years ago by bpindelski

Roger, do you want me to conduct any more tests on Windows 7? There might have been some build system updates since this issue was reported and maybe it's worth investigating if it's still present?

comment:9 Changed 6 years ago by rleigh

Hi Blazej,

I think it would be useful to know if the problem is still present on Windows. However, I think the best solution would be to switch the build to use cmake. I've already done this on develop (https://github.com/rleigh-dundee/openmicroscopy/commits/cmake) and should be able to open a PR with just a little more work; this can then be backported to dev_4_4. It will remove the need to hand-code all these little portability hacks into the scons build script since we can just create a VS project file for 32 or 64-bit builds.

comment:10 Changed 6 years ago by rleigh

Ticket #11488 opened to track the cmake work.

comment:11 Changed 6 years ago by bpindelski

After speaking to Roger, I also tend to agree that Cmake would be the way to go. Since I am not aware of any users being particularly blocked by this ticket, as the reporter I'd vote for moving it out of 4.4.9.

comment:12 Changed 6 years ago by jamoore

  • Resolution set to wontfix
  • Status changed from new to closed
  • Version set to 4.4.8

Closing in favor of #11488

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.225106 sec.)

We're Hiring!