Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #10294 (closed)

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

Bug: web hang on setGroupId?

Reported by: jamoore Owned by: wmoore
Priority: minor Milestone: OMERO-4.4.7
Component: Web Version: n.a.
Keywords: n.a. Cc: web-team@…, ux@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

On today's howe web client, I:

  • logged in as user-6 (default group was system)
  • changed to read-annotate-1
  • then the client hung (see screenshot)

It never came out of the hang. I tried to reproduce on changing to other groups, and resetting the group back and then moving again, but could not reproduce, so this may not be the core reason. In the OMEROweb.log, there is only one exception ("Group 53 was not found for user 7"). Since I was the first user of the day, this makes me think that this is related, but I'm not sure. (Log attached too)

Attachments (2)

howe-feb-5.log (25.7 KB) - added by jmoore 7 years ago.
OMEROweb.log file from howe today
ss-web-howe-hang.png (42.6 KB) - added by jmoore 7 years ago.
Spinning wheel

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by jmoore

OMEROweb.log file from howe today

Changed 7 years ago by jmoore

Spinning wheel

comment:1 Changed 7 years ago by wmoore

  • Resolution set to wontfix
  • Status changed from new to closed

The exception is caused by logout, trying to set your default group to the one you're currently looking at (which has somehow got out of sync with your login, since you're not in that group:

def logout(request, conn=None, **kwargs):
    """ Logout of the session and redirects to the homepage (will redirect to login first) """

    if request.session.get('active_group') is not None:
        try:
            conn.setDefaultGroup(request.session.get('active_group'))
        except:
            logger.error('Exception during logout.', exc_info=True)
   ...

I'm not sure if this is responsible for the hang (or if it even happened around the same time). If you can think how to reproduce it or it happens again, let me know...

comment:2 Changed 7 years ago by jmoore

  • Cc web-team@… added

Will: I don't know any more than I've listed here (though one could likely do something in the DB directly to make it happen). That being said, it's a fairly significant break, and should likely have been at something higher than "minor". If it comes up again, I highly suggest we try to nip it in the bud.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.73293 sec.)

We're Hiring!