Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #10333 (closed)

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

BUG: Error connected to group

Reported by: pwalczysko Owned by: jburel
Priority: blocker Milestone: OMERO-4.4.7
Component: Insight Version: n.a.
Keywords: n.a. Cc: ux@…, jamoore
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: 2013-02-12 (5)

Description (last modified by pwalczysko)

When testing the import of test_images_good/flex/ into Screens folder
User-4:

Go to Screens harmonica tab.

Put "zpetr test group change" out of display.

Put some other group to display, expand it, refresh.

Start import.

Choose test_images_good/flex/.

Press >

In Import Location window, choose "zpetr test group change"

The Screens choice is greyed out. (see screenshot)

Choose back any other group (e.g. private-1) - the Screen choice is not greyed out.

Choose "zpetr's test group change" again. The Screen choice is greyed out again.

Imported the /flex/ into the "zpetr test group change".

The Import reported success (green tick), but the importer line was saying "Cancel" (see screenshot).

Cancelled the importer window.

Go to the Screen harmonica in Data Manager.

Put the "zpetr test group change" to display.

Click on the "zpetr test group change" group to expand.

Error appears.

See below.

Cancelled the error.

Cllcked onto the group in the tree. Expanded and collapsed the group.

The "ScreenData?." error appeared (shown below) alternately with the "GroupData?" error which is attached as .txt.

After some expanding and collapsing, intermittently "Connection lost" appeared, then "Connection destroyed" and insight closed.

java.lang.Exception: org.openmicroscopy.shoola.env.data.DSAccessException: Cannot access data. 
Cannot load hierarchy for class pojos.ScreenData.
	at org.openmicroscopy.shoola.env.data.OMEROGateway.handleException(OMEROGateway.java:891)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.loadContainerHierarchy(OMEROGateway.java:2649)
	at org.openmicroscopy.shoola.env.data.OmeroDataServiceImpl.loadContainerHierarchy(OmeroDataServiceImpl.java:221)
	at org.openmicroscopy.shoola.env.data.views.calls.DMLoader$1.doCall(DMLoader.java:91)
	at org.openmicroscopy.shoola.env.data.views.BatchCall.doStep(BatchCall.java:144)
	at org.openmicroscopy.shoola.util.concur.tasks.CompositeTask.doStep(CompositeTask.java:226)
	at org.openmicroscopy.shoola.env.data.views.CompositeBatchCall.doStep(CompositeBatchCall.java:126)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.exec(ExecCommand.java:165)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.run(ExecCommand.java:276)
	at org.openmicroscopy.shoola.util.concur.tasks.AsyncProcessor$Runner.run(AsyncProcessor.java:91)
	at java.lang.Thread.run(Thread.java:680)
Caused by: Ice.CommunicatorDestroyedException
	at IceInternal.Instance.objectAdapterFactory(Instance.java:122)
	at Ice.ObjectPrxHelperBase.createDelegate(ObjectPrxHelperBase.java:997)
	at Ice.ObjectPrxHelperBase.__getDelegate(ObjectPrxHelperBase.java:946)
	at omero.api.IContainerPrxHelper.loadContainerHierarchy(IContainerPrxHelper.java:736)
	at omero.api.IContainerPrxHelper.loadContainerHierarchy(IContainerPrxHelper.java:710)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.loadContainerHierarchy(OMEROGateway.java:2645)
	... 9 more

	at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.showErrorDialog(UserNotifierImpl.java:189)
	at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.notifyError(UserNotifierImpl.java:287)
	at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.notifyError(UserNotifierImpl.java:257)
	at org.openmicroscopy.shoola.agents.treeviewer.DataBrowserLoader.handleException(DataBrowserLoader.java:148)
	at org.openmicroscopy.shoola.env.data.events.DSCallAdapter.eventFired(DSCallAdapter.java:84)
	at org.openmicroscopy.shoola.env.data.views.BatchCallMonitor$1.run(BatchCallMonitor.java:124)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:702)
	at java.awt.EventQueue.access$400(EventQueue.java:82)
	at java.awt.EventQueue$2.run(EventQueue.java:663)
	at java.awt.EventQueue$2.run(EventQueue.java:661)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:672)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:205)
	at java.awt.Dialog$1.run(Dialog.java:1044)
	at java.awt.Dialog$3.run(Dialog.java:1096)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1094)
	at java.awt.Component.show(Component.java:1591)
	at java.awt.Component.setVisible(Component.java:1543)
	at java.awt.Window.setVisible(Window.java:843)
	at java.awt.Dialog.setVisible(Dialog.java:984)
	at org.openmicroscopy.shoola.util.ui.UIUtilities.centerAndShow(UIUtilities.java:557)
	at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.showErrorDialog(UserNotifierImpl.java:197)
	at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.notifyError(UserNotifierImpl.java:287)
	at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.notifyError(UserNotifierImpl.java:257)
	at org.openmicroscopy.shoola.agents.metadata.MetadataLoader.handleException(MetadataLoader.java:169)
	at org.openmicroscopy.shoola.env.data.events.DSCallAdapter.eventFired(DSCallAdapter.java:84)
	at org.openmicroscopy.shoola.env.data.views.BatchCallMonitor$1.run(BatchCallMonitor.java:124)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:702)
	at java.awt.EventQueue.access$400(EventQueue.java:82)
	at java.awt.EventQueue$2.run(EventQueue.java:663)
	at java.awt.EventQueue$2.run(EventQueue.java:661)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:672)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (4)

pending import which finished.png (35.9 KB) - added by pwalczysko 7 years ago.
error group data.txt (3.4 KB) - added by pwalczysko 7 years ago.
Screen choice greyed out.png (34.9 KB) - added by pwalczysko 7 years ago.
4.4.5 version works fine.png (44.7 KB) - added by pwalczysko 7 years ago.

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by pwalczysko

comment:1 Changed 7 years ago by pwalczysko

  • Description modified (diff)

Changed 7 years ago by pwalczysko

comment:2 Changed 7 years ago by pwalczysko

  • Description modified (diff)

Changed 7 years ago by pwalczysko

Changed 7 years ago by pwalczysko

comment:3 Changed 7 years ago by pwalczysko

This bug looks like fixed now - retested with version OMERO.insight-4.4.5-622-3e1b36a-dirty-ice33-b151-mac.

Last edited 7 years ago by pwalczysko (previous) (diff)

comment:4 Changed 7 years ago by jburel

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 7 years ago by sylittlewood

Tested using the following process. This is now fixed and works correctly.

  1. login as user-4:ome - zpetr's group should be selected & visible
  2. show read-only group -> tick [show group] -> [update]
  3. right click user-4 in zpetr group -> [import...]
  4. select an image / folder -> add to list [>]
  5. in location dialogue select zpetr group (don't change proj/dataset) -> [close]
  6. don;t close import dialogue, go back to data manager
  7. hide zpetr group from the tree -> untick [show group] -> [update]
  8. right click user-4 in read-only group -> [import]
  9. select an image / folder -> add to list [>]
  10. change group to zpetr group in lcoation dialogue

comment:6 Changed 7 years ago by jburel <j.burel@…>

(In [ad5d2cadc39b117908bb103c95b0d4b94046fbb2/ome.git] on branch develop) Fix loading of data (see #10333)

comment:7 Changed 7 years ago by jburel <j.burel@…>

(In [24415915be65d3285289f8a938bd22ace0ad5e11/ome.git] on branch develop) Make sure the reference to the connector is removed (see #10333)

comment:8 Changed 7 years ago by Josh Moore <josh@…>

(In [308e89b5edff6863716c9b83442c0852f5de5713/ome.git] on branch develop) Merge pull request #713 from jburel/group-display-develop

Make sure the reference to the connector is removed (see #10333)

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.432645 sec.)

We're Hiring!