Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Bug #10364 (closed)

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

Clicked Dataset, Crash

Reported by: khgillen Owned by: jburel
Priority: critical Cc: ux@…, fs@…
Sprint: 2013-02-12 (5)
Total Remaining Time: n.a.

Description

user-5, insight 4.4.6 client (build 102) connecting to Gretzky
cellsens -> brian

action: click on the dataset brian, before anything else happened, insight crashed with following error message:

java.lang.Exception: org.openmicroscopy.shoola.env.data.DSAccessException: Cannot access data. 
Cannot load hierarchy for class pojos.DatasetData.
	at org.openmicroscopy.shoola.env.data.OMEROGateway.handleException(OMEROGateway.java:891)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.loadContainerHierarchy(OMEROGateway.java:2649)
	at org.openmicroscopy.shoola.env.data.OmeroDataServiceImpl.loadContainerHierarchy(OmeroDataServiceImpl.java:221)
	at org.openmicroscopy.shoola.env.data.views.calls.DMLoader$1.doCall(DMLoader.java:91)
	at org.openmicroscopy.shoola.env.data.views.BatchCall.doStep(BatchCall.java:144)
	at org.openmicroscopy.shoola.util.concur.tasks.CompositeTask.doStep(CompositeTask.java:226)
	at org.openmicroscopy.shoola.env.data.views.CompositeBatchCall.doStep(CompositeBatchCall.java:126)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.exec(ExecCommand.java:165)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.run(ExecCommand.java:276)
	at org.openmicroscopy.shoola.util.concur.tasks.AsyncProcessor$Runner.run(AsyncProcessor.java:91)
	at java.lang.Thread.run(Thread.java:680)
Caused by: Ice.UnmarshalOutOfBoundsException
    reason = (null)
	at IceInternal.BasicStream.readString(BasicStream.java:1347)
	at IceInternal.BasicStream.readTypeId(BasicStream.java:665)
	at omero.model.IObject.__read(IObject.java:462)
	at omero.model.Image.__read(Image.java:2455)
	at IceInternal.BasicStream.readObject(BasicStream.java:1590)
	at IceInternal.BasicStream.readPendingObjects(BasicStream.java:1739)
	at omero.api._IContainerDelM.loadContainerHierarchy(_IContainerDelM.java:607)
	at omero.api.IContainerPrxHelper.loadContainerHierarchy(IContainerPrxHelper.java:738)
	at omero.api.IContainerPrxHelper.loadContainerHierarchy(IContainerPrxHelper.java:710)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.loadContainerHierarchy(OMEROGateway.java:2645)
	... 9 more

	at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.showErrorDialog(UserNotifierImpl.java:189)
	at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.notifyError(UserNotifierImpl.java:287)
	at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.notifyError(UserNotifierImpl.java:257)
	at org.openmicroscopy.shoola.agents.treeviewer.DataBrowserLoader.handleException(DataBrowserLoader.java:148)
	at org.openmicroscopy.shoola.env.data.events.DSCallAdapter.eventFired(DSCallAdapter.java:84)
	at org.openmicroscopy.shoola.env.data.views.BatchCallMonitor$1.run(BatchCallMonitor.java:124)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:702)
	at java.awt.EventQueue.access$400(EventQueue.java:82)
	at java.awt.EventQueue$2.run(EventQueue.java:663)
	at java.awt.EventQueue$2.run(EventQueue.java:661)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:672)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (1)

Screen Shot 2013-02-11 at 17.06.59.png (170.7 KB) - added by khgillen 11 years ago.
screenshot of crash

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by khgillen

screenshot of crash

comment:1 Changed 11 years ago by jburel

  • Resolution set to invalid
  • Status changed from new to closed

The client and server are not compatible. So it will not work

comment:2 Changed 11 years ago by jmoore

  • Cc fs@… added; jmoore removed

J-M: and we're not catching this yet because gretzky is still at 4.4.x right? So at the latest when we tag for the Feb. demo then the version will go to 5.0.x and it should be fixed. Perhaps when we start another branch we should always immediately tag to something like 5.0-START to prevent this.

Adding fs@ in order to make sure everyone knows of the potential confusion.

(Is there any way we can add special handling for this type of exception? Similar to the version mismatch?)

comment:3 Changed 11 years ago by jburel

That is correct. The issue was raised by Colin a while ago. I did some work on a branch at the time but we did not go ahead since the server version did not get modified.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.66227 sec.)

We're Hiring!