Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #10525 (closed)

Opened 11 years ago

Closed 11 years ago

BUG:Feedback 4965

Reported by: omero-qa Owned by: mlinkert
Priority: minor Milestone: Unscheduled
Component: Bio-Formats Version: n.a.
Keywords: n.a. Cc: rebecca.billig@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

http://qa.openmicroscopy.org.uk/qa/feedback/4965/

Exception while trying to read pixel data. Reproducible on dev_4_4 including with your bug-week branch merged in. Please could you copy /ome/apache_repo/4965/2012_10_31_GFPbiflinmKate_29hpf_20x_1.2_7_001.tif and
/ome/apache_repo/4966/2012_10_31_GFPbiflinmKate_29hpf_40x_4.6z_001.tif to from_skyking? From showinf:

Reading pixel data (0-0)
Exception in thread "main" loci.formats.FormatException: java.io.EOFException: Attempting to read beyond end of file.
	at loci.formats.codec.BaseCodec.decompress(BaseCodec.java:188)
	at loci.formats.tiff.TiffCompression.decompress(TiffCompression.java:278)
	at loci.formats.tiff.TiffParser.getTile(TiffParser.java:699)
	at loci.formats.tiff.TiffParser.getSamples(TiffParser.java:916)
	at loci.formats.tiff.TiffParser.getSamples(TiffParser.java:739)
	at loci.formats.in.MinimalTiffReader.openBytes(MinimalTiffReader.java:292)
	at loci.formats.DelegateReader.openBytes(DelegateReader.java:211)
	at loci.formats.ImageReader.openBytes(ImageReader.java:414)
	at loci.formats.ReaderWrapper.openBytes(ReaderWrapper.java:317)
	at loci.formats.MinMaxCalculator.openBytes(MinMaxCalculator.java:273)
	at loci.formats.MinMaxCalculator.openBytes(MinMaxCalculator.java:265)
	at loci.formats.ReaderWrapper.openBytes(ReaderWrapper.java:305)
	at loci.formats.tools.ImageInfo.readPixels(ImageInfo.java:782)
	at loci.formats.tools.ImageInfo.testRead(ImageInfo.java:1000)
	at loci.formats.tools.ImageInfo.main(ImageInfo.java:1031)
Caused by: java.io.EOFException: Attempting to read beyond end of file.
	at loci.common.ByteArrayHandle.readByte(ByteArrayHandle.java:204)
	at loci.common.RandomAccessInputStream.readByte(RandomAccessInputStream.java:353)
	at loci.common.RandomAccessInputStream.read(RandomAccessInputStream.java:470)
	at loci.formats.codec.LZWCodec.decompress(LZWCodec.java:320)
	at loci.formats.codec.BaseCodec.decompress(BaseCodec.java:183)
	... 14 more

Change History (2)

comment:1 Changed 11 years ago by rleigh

  • Component changed from from QA to Bio-Formats
  • Owner changed from mlinkert-x to mlinkert

comment:2 Changed 11 years ago by mlinkert

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with: https://github.com/openmicroscopy/bioformats/pull/419

Note that a new build with this fix is not yet available.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.64826 sec.)

We're Hiring!