Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #10665 (closed)

Opened 9 years ago

Closed 8 years ago

BUG: Thumbnails not showing in Web after "Import As"

Reported by: rkferguson Owned by: jburel
Priority: blocker Milestone: OMERO-4.4.9
Component: Insight Version: 4.4.8
Keywords: n.a. Cc: web-team@…, ux@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

Howe Mac OS - Insight - Scott's special build, Web Safari

Did "Import As" testing in Insight - all worked as expected.

Opened Web client and logged in as user-6 - the admin who had been doing the "Import As".
Changed to 'read-annotate-1" but could not view all members of group due to drop-down menu issue (known) - could see user-6 data in group and all looked as expected.

Logged out and in as user-3 (ordinary member of read-annotate-1 who user-6 had been "Importing As").
Changed to "All Members" view.
Could see all data "Imported As" in data tree, but in centre pane, could only see thumbnails for data owned by user-3, that owned by user-6 and user-11 had no thumbnails, but could still view the images even if no were thumbnails showing.
All permissions were as expected.

Did a refresh of data tree and all thumbnails then appeared as expected.

Logged out and logged in as user-11 - in All Members view - all thumbnails were visible as expected.
Logged back in as user-3 - now all thumbnails were visible as expected in All Members view.

So it appears to be that the refresh triggers an update to thumbnail status/creation for images not owned by current user that is not happening automatically on import.

Change History (10)

comment:1 Changed 9 years ago by wmoore

This sounds very similar to various issues described in #10618

comment:2 Changed 9 years ago by jburel

I will also investigate to check that we have the correct user as the owner of the rendering settings.

comment:3 Changed 9 years ago by jburel

  • Sprint changed from 2013-04-09 (7)) to 2013-05-07 (8)

Moved from sprint 2013-04-09 (7))

comment:4 Changed 9 years ago by jamoore

  • Cc web-team@… ux@… added; mailto:web-team@… removed
  • Milestone changed from OMERO-4.4.x to OMERO-4.4.9
  • Priority changed from major to blocker
  • Sprint 2013-05-07 (8) deleted

Moving to 4.4.9 as blocker to be evaluated along with #10618.

comment:5 Changed 8 years ago by jburel

similar to #11427

comment:6 Changed 8 years ago by jburel

tested the following: Image imported by user-6 (admin)

  • private
    • import for user-2 (member). Go to web. Thumbnail visible
    • import for user-3 (group owner). Go to web. Thumbnail visible
  • read-only
    • import for user-2 (member). Go to web. Thumbnail visible
    • import for user-3 (group owner). Go to web. Thumbnail visible
  • read-annotate
    • import for user-3 (member). Go to web. Thumbnail visible
    • import for user-5 (group owner). Go to web. Thumbnail visible
Last edited 8 years ago by jburel (previous) (diff)

comment:7 Changed 8 years ago by jburel

Tried to reproduce the issue described above but no success.
I will re-import data and do no log in as data owner to look at them.

comment:8 Changed 8 years ago by jburel

Gus: I have not been able to reproduce the issue. Have you seen the problem recently again since the ticket is 6 months old?

comment:9 Changed 8 years ago by pwalczysko

Not seeing it either - testing this as a part of 4.4.9 pre-release testing of Import As scenario - all visible in web straight after login.

comment:10 Changed 8 years ago by jburel

  • Resolution set to invalid
  • Status changed from new to closed
  • Version set to 4.4.8

Thanks Petr. Marking the ticket as invalid. Feel free to re-open if the problem reappears.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.77586 sec.)

We're Hiring!