Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #10717 (closed)

Opened 8 years ago

Closed 8 years ago

BUG: Import of flex from skyking fails

Reported by: pwalczysko Owned by:
Priority: major Milestone: 5.0.0-beta1
Component: Import Version: n.a.
Keywords: FS Cc: ux@…, fs@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: FS Demo 3

Description

File:
from_skyking/flex/karsten/Opera/Reference Data/Meas_01(2008-06-12_12-32-02)...

Importing to Gretzky using build OMERO.insight-5.0.0-alpha1-991-5003e8b-dirty-ice33-b230-mac

loci.formats.MissingLibraryException: The LuraWave decoding library, lwf_jsdk2.6.jar, is required to decode this file.
Please make sure it is present in your classpath.
	at loci.formats.codec.LuraWaveCodec.initialize(LuraWaveCodec.java:168)
	at loci.formats.codec.LuraWaveCodec.decompress(LuraWaveCodec.java:100)
	at loci.formats.tiff.TiffCompression.decompress(TiffCompression.java:278)
	at loci.formats.tiff.TiffParser.getTile(TiffParser.java:699)
	at loci.formats.tiff.TiffParser.getSamples(TiffParser.java:916)
	at loci.formats.tiff.TiffParser.getSamples(TiffParser.java:739)
	at loci.formats.in.FlexReader.openBytes(FlexReader.java:255)
	at loci.formats.ImageReader.openBytes(ImageReader.java:414)
	at loci.formats.ChannelFiller.openBytes(ChannelFiller.java:197)
	at loci.formats.ChannelSeparator.openBytes(ChannelSeparator.java:226)
	at loci.formats.ReaderWrapper.openBytes(ReaderWrapper.java:317)
	at loci.formats.MinMaxCalculator.openBytes(MinMaxCalculator.java:273)
	at ome.formats.importer.ImportLibrary.writeDataTileBased(ImportLibrary.java:885)
	at ome.formats.importer.ImportLibrary.importData(ImportLibrary.java:810)
	at ome.formats.importer.ImportLibrary.importImage(ImportLibrary.java:586)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.importImage(OMEROGateway.java:6736)
	at org.openmicroscopy.shoola.env.data.OmeroImageServiceImpl.importFile(OmeroImageServiceImpl.java:1318)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.importFile(ImagesImporter.java:77)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.access$000(ImagesImporter.java:53)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter$1.doCall(ImagesImporter.java:102)
	at org.openmicroscopy.shoola.env.data.views.BatchCall.doStep(BatchCall.java:144)
	at org.openmicroscopy.shoola.util.concur.tasks.CompositeTask.doStep(CompositeTask.java:226)
	at org.openmicroscopy.shoola.env.data.views.CompositeBatchCall.doStep(CompositeBatchCall.java:126)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.exec(ExecCommand.java:165)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.run(ExecCommand.java:276)
	at org.openmicroscopy.shoola.util.concur.tasks.AsyncProcessor$Runner.run(AsyncProcessor.java:91)
	at java.lang.Thread.run(Thread.java:680)
Caused by: Unable to instantiate service for interface loci.formats.services.LuraWaveService
	at loci.common.services.ServiceFactory.getInstance(ServiceFactory.java:173)
	at loci.formats.codec.LuraWaveCodec.initialize(LuraWaveCodec.java:165)
	... 26 more
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
	at loci.common.services.ServiceFactory.getInstance(ServiceFactory.java:171)
	... 27 more
Caused by: java.lang.NoClassDefFoundError: com/luratech/lwf/lwfDecoder
	at loci.formats.services.LuraWaveServiceImpl.<init>(LuraWaveServiceImpl.java:89)
	... 32 more

	at org.openmicroscopy.shoola.env.data.OMEROGateway.importImage(OMEROGateway.java:6790)
	at org.openmicroscopy.shoola.env.data.OmeroImageServiceImpl.importFile(OmeroImageServiceImpl.java:1318)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.importFile(ImagesImporter.java:77)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.access$000(ImagesImporter.java:53)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter$1.doCall(ImagesImporter.java:102)
	at org.openmicroscopy.shoola.env.data.views.BatchCall.doStep(BatchCall.java:144)
	at org.openmicroscopy.shoola.util.concur.tasks.CompositeTask.doStep(CompositeTask.java:226)
	at org.openmicroscopy.shoola.env.data.views.CompositeBatchCall.doStep(CompositeBatchCall.java:126)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.exec(ExecCommand.java:165)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.run(ExecCommand.java:276)
	at org.openmicroscopy.shoola.util.concur.tasks.AsyncProcessor$Runner.run(AsyncProcessor.java:91)
	at java.lang.Thread.run(Thread.java:680)
Caused by: loci.formats.MissingLibraryException: The LuraWave decoding library, lwf_jsdk2.6.jar, is required to decode this file.
Please make sure it is present in your classpath.
	at loci.formats.codec.LuraWaveCodec.initialize(LuraWaveCodec.java:168)
	at loci.formats.codec.LuraWaveCodec.decompress(LuraWaveCodec.java:100)
	at loci.formats.tiff.TiffCompression.decompress(TiffCompression.java:278)
	at loci.formats.tiff.TiffParser.getTile(TiffParser.java:699)
	at loci.formats.tiff.TiffParser.getSamples(TiffParser.java:916)
	at loci.formats.tiff.TiffParser.getSamples(TiffParser.java:739)
	at loci.formats.in.FlexReader.openBytes(FlexReader.java:255)
	at loci.formats.ImageReader.openBytes(ImageReader.java:414)
	at loci.formats.ChannelFiller.openBytes(ChannelFiller.java:197)
	at loci.formats.ChannelSeparator.openBytes(ChannelSeparator.java:226)
	at loci.formats.ReaderWrapper.openBytes(ReaderWrapper.java:317)
	at loci.formats.MinMaxCalculator.openBytes(MinMaxCalculator.java:273)
	at ome.formats.importer.ImportLibrary.writeDataTileBased(ImportLibrary.java:885)
	at ome.formats.importer.ImportLibrary.importData(ImportLibrary.java:810)
	at ome.formats.importer.ImportLibrary.importImage(ImportLibrary.java:586)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.importImage(OMEROGateway.java:6736)
	... 11 more
Caused by: Unable to instantiate service for interface loci.formats.services.LuraWaveService
	at loci.common.services.ServiceFactory.getInstance(ServiceFactory.java:173)
	at loci.formats.codec.LuraWaveCodec.initialize(LuraWaveCodec.java:165)
	... 26 more
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
	at loci.common.services.ServiceFactory.getInstance(ServiceFactory.java:171)
	... 27 more
Caused by: java.lang.NoClassDefFoundError: com/luratech/lwf/lwfDecoder
	at loci.formats.services.LuraWaveServiceImpl.<init>(LuraWaveServiceImpl.java:89)
	... 32 more

Change History (1)

comment:1 Changed 8 years ago by mlinkert

  • Resolution set to invalid
  • Status changed from new to closed

That is expected and not a bug. Some of the data in from_skyking/flex/ needs an extra .jar, which we can't distribute.

See #4165.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.66070 sec.)

We're Hiring!