Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #10770 (closed)

Opened 11 years ago

Closed 11 years ago

BUG: ome_tools.jar exception

Reported by: pwalczysko Owned by: mlinkert
Priority: critical Milestone: OMERO-4.4.9
Component: Bio-Formats Version: 4.4.8
Keywords: n.a. Cc: ux@…, rleigh, mlinkert, jamoore, jamoore, sbesson
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

Download most recent ImageJ from IJ homepage.
Download RC1 tagged version for 4.4.7 release of ome-tools.jar and loci_tools.jar from https://www.openmicroscopy.org/site/products/bio-formats/copy_of_downloads.
Put the downloaded ome-tools.jar and loci_tools.jar into Plugins folder of the ImageJ.
Start IJ. Go Plugins > OME > Download from OMERO.
OMERO Server Credentials window appears.
Login to howe, user-6, into the last line put an existing image ID.
Exception appears - see below.
(if you try to put and existing, correct group name into the "Group" line of the OMERO Server Credentioals window, the bug appears anyway)

Ice.MarshalException
    reason = (null)
	at Ice.ObjectImpl.__read(ObjectImpl.java:255)
	at omero.model.Details.__read(Details.java:495)
	at IceInternal.BasicStream.readObject(BasicStream.java:1590)
	at IceInternal.BasicStream.readPendingObjects(BasicStream.java:1739)
	at omero.api._IAdminDelM.getDefaultGroup(_IAdminDelM.java:1040)
	at omero.api.IAdminPrxHelper.getDefaultGroup(IAdminPrxHelper.java:1351)
	at omero.api.IAdminPrxHelper.getDefaultGroup(IAdminPrxHelper.java:1323)
	at loci.ome.io.OmeroReader.initFile(OmeroReader.java:265)
	at loci.formats.FormatReader.setId(FormatReader.java:1183)
	at loci.plugins.in.ImportProcess.initializeFile(ImportProcess.java:482)
	at loci.plugins.in.ImportProcess.execute(ImportProcess.java:146)
	at loci.plugins.in.Importer.showDialogs(Importer.java:141)
	at loci.plugins.in.Importer.run(Importer.java:79)
	at loci.plugins.LociImporter.run(LociImporter.java:81)
	at ij.IJ.runUserPlugIn(IJ.java:185)
	at ij.IJ.runPlugIn(IJ.java:152)
	at ij.Executer.runCommand(Executer.java:127)
	at ij.Executer.run(Executer.java:64)
	at java.lang.Thread.run(Thread.java:680)

Change History (10)

comment:1 Changed 11 years ago by pwalczysko

  • Cc sbesson added

comment:2 Changed 11 years ago by jamoore

Is it possible that this was communicating with gretzky? i.e. mixed 4.4/5.0?

comment:3 Changed 11 years ago by mlinkert

Can duplicate by connecting to howe. The issue is that ome_tools.jar contains an old version of omero_client.jar. We haven't been supporting "Plugins > OME > Download from OMERO", since the Insight ImageJ plugin is much more usable, so I'd be in favor of fixing this by deprecating that plugin.

comment:4 Changed 11 years ago by pwalczysko

Deprecating seems much better than releasing broken .jar.

comment:5 Changed 11 years ago by mlinkert

Just going to add one more commit to https://github.com/openmicroscopy/bioformats/pull/478 that tells the user to use the Insight ImageJ plugin when "Plugins > OME > Download from OMERO" is clicked then (as mentioned in devteam).

comment:6 Changed 11 years ago by sbesson

Added commit to the Bio-Formats downloads page PR https://github.com/openmicroscopy/ome-release/pull/5 to move ome_tools.jar down to the component builds table.

comment:7 Changed 11 years ago by jamoore

As for changing the UI in imagej, can I propose that this get pushed to 4.4.8 as critical or even blocker, but that since this was in 4.4.6 and before, we not try to fix it for 4.4.7?

comment:8 Changed 11 years ago by pwalczysko

@jamoore: np for me

comment:9 Changed 11 years ago by mlinkert

  • Milestone changed from OMERO-4.4.7 to OMERO-4.4.8
  • Sprint 2013-05-07 (8) deleted

comment:10 Changed 11 years ago by mlinkert

  • Resolution set to fixed
  • Status changed from new to closed
  • Version set to 4.4.8
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.67146 sec.)

We're Hiring!