Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

User Story #10771 (closed)

Opened 11 years ago

Closed 9 years ago

Handling of MIF in clients

Reported by: bpindelski Owned by:
Priority: critical Milestone: 5.x
Component: General Keywords: n.a.
Cc: wmoore, fs@…, ux@… Story Points: n.a.
Sprint: n.a. Importance: n.a.
Total Remaining Time: 0.0d Estimated Remaining Time: n.a.

Description (last modified by jamoore)

Multi-image filesets (MIFs) are logically grouped into filesets during import time. The clients (Insigh, Web) need to provide the user with feedback when certain operations are performed on them.

Current state

The 2 primary operations under consideration are chgrp and delete.

Chrgrp is an issue since it is not currently possible to have the same underlying binary data (the original filesets) contained in 2 separate groups. Therefore if one image from an MIF is moved to another group, it will become unviewable. Therefore, for demo 2, the chgrp operation was completely disallowed.

Delete is an issue because a user may accidentally delete more data than was intended. One image of an MIF present in a dataset that is being deleted, does not guarantee that the user intended to delete all the other images in the MIF in all datasets. The current state of delete as of demo 3 is that dangerous deletes are permitted.

Goals for demo 4

Primarily, this story is about getting these permission-related operations for MIFs into a generally releasable state. There are further, more extensive solutions possible (including deep copies and an abstracted IO system) but these will only be considered once base functionality is in a "safe" state. The changes to bring us there include:

  • graph definitions on the server should be conservative by default, preventing users from doing things they don't expect;
  • clients need to be aware of this conservative behavior and inform users of possible corrective actions;
  • and where possible, clients should provide users feedback (and "training") about what MIFs via subtle hints in the UI.


Change History (4)

comment:1 Changed 11 years ago by jamoore

  • Cc wmoore ux@… added
  • Description modified (diff)

comment:2 Changed 11 years ago by jamoore

  • Description modified (diff)
  • Summary changed from Handling of MFI in clients to Handling of MIF in clients

comment:3 Changed 11 years ago by agilo

  • Status changed from new to accepted

Updated status, related task in progress

comment:4 Changed 9 years ago by jamoore

  • Cc changed from wmoore, fs@openmicroscopy.org.uk, ux@openmicroscopy.org.uk, to wmoore, fs@openmicroscopy.org.uk, ux@openmicroscopy.org.uk
  • Resolution set to fixed
  • Status changed from accepted to closed

All tasks closed.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.122449 sec.)

We're Hiring!