Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #10772 (closed)

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

Bug: IndexOutOfBoundsException during import in Insight

Reported by: mtbcarroll Owned by: bpindelski
Priority: blocker Milestone: 5.0.0-beta1
Component: Import Version: n.a.
Keywords: n.a. Cc: jburel
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: FS demo 4.1

Description

On current gretzky, if I try to import data_repo/test_images_metadata/leica-lif/Rosier.lif or a MIAS plate or various other files, Insight gives me,

java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
	at java.util.ArrayList.RangeCheck(ArrayList.java:547)
	at java.util.ArrayList.get(ArrayList.java:322)
	at org.openmicroscopy.shoola.agents.fsimporter.util.FileImportComponent.getFileSetID(FileImportComponent.java:840)
	at org.openmicroscopy.shoola.agents.fsimporter.util.FileImportComponent.setStatus(FileImportComponent.java:1124)
	at org.openmicroscopy.shoola.agents.fsimporter.view.ImporterUIElement.setImportedFile(ImporterUIElement.java:722)
	at org.openmicroscopy.shoola.agents.fsimporter.view.ImporterComponent.setImportedFile(ImporterComponent.java:316)
	at org.openmicroscopy.shoola.agents.fsimporter.ImagesImporter.update(ImagesImporter.java:121)
	at org.openmicroscopy.shoola.env.data.events.DSCallAdapter.eventFired(DSCallAdapter.java:75)
	at org.openmicroscopy.shoola.env.data.views.BatchCallMonitor$1.run(BatchCallMonitor.java:124)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:708)
	at java.awt.EventQueue.access$400(EventQueue.java:82)
	at java.awt.EventQueue$2.run(EventQueue.java:669)
	at java.awt.EventQueue$2.run(EventQueue.java:667)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:678)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Change History (9)

comment:1 Changed 11 years ago by bpindelski

  • Remaining Time set to 1
  • Status changed from new to accepted

comment:2 Changed 11 years ago by bpindelski

If testing locally, this needs Colin's import log file branch merged in.

comment:3 Changed 11 years ago by pwalczysko

@bpindelski : not sure - I think I do not have this branch https://github.com/openmicroscopy/openmicroscopy/pull/1062 in - I did not merge it knowingly, and also my subsequent check did not find the commits from this branch in my local branch => I did not have it merged in. All I have is josh's kryo-memoizer and josh's fs-file-caching. This is all I have merged in. But, I still get the bug on my local build.

comment:4 Changed 11 years ago by bpindelski

This is indirectly caused by the setStatus() method in FileImportComponent in Insight. The method modifies the passed in list of images, and then when the getFileSetID() method gets executed, the list is empty, hence the exception. More investigation needed to find a fix.

comment:5 Changed 11 years ago by pwalczysko

Hit this exception again importing zeiss-czi/raw.czi. During testing of https://github.com/openmicroscopy/bioformats/pull/491.

comment:7 Changed 11 years ago by bpindelski

  • Remaining Time changed from 1 to 0
  • Resolution set to fixed
  • Status changed from accepted to closed

comment:8 Changed 11 years ago by Blazej Pindelski <bpindelski@…>

(In [dcfdf34fe0b4a8253840d965a83960c5656c29fd/ome.git] on branch develop) Fix IOOB when importing MIFs (see #10772)

comment:9 Changed 11 years ago by Josh Moore <josh@…>

(In [43b619ab2eda7230a9e67cef5c0dfb16b68d1c49/ome.git] on branch develop) Merge pull request #1116 from bpindelski/ioob-import

Fix IOOB when importing MIFs (see #10772)

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.64576 sec.)

We're Hiring!