Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #10834 (closed)

Opened 8 years ago

Closed 8 years ago

Fix OMERO virtualbox artifacts overwriting

Reported by: sbesson Owned by: sbesson
Priority: major Milestone: OMERO-4.4.9
Component: General Version: 4.4.8
Keywords: n.a. Cc: jamoore, khgillen
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

Currently the OMERO-stable-virtualbox and OMERO-trunk-virtualbox jobs are both copying the created ova to necromancer as /ome/data_repo/virtualbox/omero-vm-latest-build.ova

The problem is that the latest vm is overwritten by any of these 2 jobs. This is a major issue especially during release process. For 4.4.8 release, OMERO-trunk-virtualbox has been temporarily disabled to fix this issue.

A possible solution is to use the same strategy as for the other release artifacts, namely copy artifacts to /ome/data_repo/releases as a promotion step. Then prep.sh under ome-release.git would have to be modified to symlink this promoted artifact during release process.

Change History (2)

comment:1 Changed 8 years ago by jamoore

  • Owner set to sbesson
  • Version set to 4.4.8

Sebastien: this can be closed now, no?

comment:2 Changed 8 years ago by sbesson

  • Resolution set to fixed
  • Status changed from new to closed

Fixed as part of the 5.0.0-beta1 release process

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.70411 sec.)

We're Hiring!