Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #10836 (closed)

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

BUG: Imprt of plates on develop

Reported by: pwalczysko Owned by: mtbcarroll
Priority: blocker Milestone: 5.0.0-beta1
Component: Import Version: n.a.
Keywords: n.a. Cc: ux@…, fs@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: FS demo 4.2

Description

The import of plates on develop (today's build, ran against Gretzky) is broken.

  • Import a plate, make sure you select a Screen as a destination
  • After successful import, the plate is not displayed in the Screens tab, but in the Orphaned images of the target group.
  • The plate appears to be in Orphaned folder in Insight as well as in Web.
  • repeat the import, this time create a new screen at import stage
  • again, the plate lands in Orphaned images folder, but the newly created screen is present under "Screens" tab as expected, except that empty
  • imported files : test_images_good/cellworx/plate 1, test_images_good/bd-pathway

Attachments (1)

plates end up in Orphaned images.png (19.2 KB) - added by pwalczysko 8 years ago.

Download all attachments as: .zip

Change History (18)

Changed 8 years ago by pwalczysko

comment:1 Changed 8 years ago by pwalczysko

comment:2 Changed 8 years ago by jamoore

  • Sprint changed from FS demo 4.1 to FS demo 4.x

Moved from sprint FS demo 4.1

comment:3 Changed 8 years ago by pwalczysko

During Demo 4.1 the suggestion was made to concentrate on Screens / HCS data by Chris. Thus, this bug will be very relevant for the next demo, as it breaks SPW workflow. Moving to FS demo 4.2

comment:4 Changed 8 years ago by pwalczysko

  • Sprint changed from FS demo 4.x to FS demo 4.2

comment:5 Changed 8 years ago by pwalczysko

  • Component changed from Import to Insight
  • Owner set to jburel

comment:6 Changed 8 years ago by bpindelski

After switching many times between branches and repositories, it has been discovered that this issue happens currently only on gretzky. I've built snoopy's merge/develop/latest branch locally (./build.py && ./build.py release-clients). Using Insight I tried connecting to both localhost and gretzky (no connection issues). When importing bd_pathway on gretzky, the screen lands in Orphaned Images. On localhost it ends up in the Screens tab. Also tried Insight from the OMERO-merge-develop job - same result.

comment:7 Changed 8 years ago by bpindelski

Tried CLI import between localhost and gretzky (also with bd-pathway). There is a major difference in the output.
When importing to gretzky I get

2013-05-16 16:41:14,145 28792      [      main] INFO   ormats.importer.cli.LoggingImportMonitor  - IMPORT_DONE Imported file: /Users/bpindelski/Desktop/testing/import/bd-pathway/2009-05-01_000/Experiment.exp
Imported pixels:
680
681
682
683
684
685
686
687
688
689
690
691
Other imported objects:
Fileset:60
Image:680
Image:681
Image:682
Image:683
Image:684
Image:685
Image:686
Image:687
Image:688
Image:689
Image:690
Image:691

Whereas the localhost import doesn't have the Image: xx lines. Instead it has

Other imported objects:
Fileset:4
Plate:4

comment:8 Changed 8 years ago by jburel

  • Component changed from Insight to Import
  • Owner jburel deleted

Not client issue, it seems to work for a flex with one well but not for other plates.

Last edited 8 years ago by jburel (previous) (diff)

comment:9 Changed 8 years ago by mtbcarroll

  • Owner set to mtbcarroll
  • Status changed from new to accepted

comment:10 Changed 8 years ago by mtbcarroll

Yes, this seems to happen only on gretzky, not locally.

Trying the same import on both, two things are different in the logs,

  • locally during step 1 I get UPDATE,class ome.model.roi.Roi entries that don't occur on gretzky
  • locally I get a lot more log output for step 3; there is hardly any on gretzky.

comment:11 Changed 8 years ago by mtbcarroll

Another striking difference on gretzky is,

omero=# select count(*) from image where name like '%[Well%]%';
 count 
-------
    64
(1 row)

omero=# select count(*) from wellsample;
 count 
-------
     0
(1 row)

comment:12 Changed 8 years ago by mtbcarroll

gretzky does have somewhat older software installed than probably what we have tried locally,

omero@gretzky:~$ java -version
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01, mixed mode)
omero@gretzky:~$ dpkg -s postgresql | grep ^Version
Version: 8.4.12-0ubuntu10.04

comment:13 Changed 8 years ago by mtbcarroll

OMERO.server-5.0.0-alpha3-3-613043e-dirty-ice33-b282.zip from gretzky running on a local virtual Linux box with Ice 3.3, Python 2.6.6, Java 1.6.0_26, PostgreSQL 8.4.13 doesn't exhibit the bug.

comment:14 Changed 8 years ago by mtbcarroll

I am observing exactly this bug also with data_repo/from_skyking/mias/frans/siRNA_PRIM1_03102008/001-365700055641/

comment:15 Changed 8 years ago by jamoore

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:16 Changed 8 years ago by jmoore <josh@…>

  • Remaining Time set to 0

(In [19460504d0ad24fcca42e76fbf5db5b319574bc2/ome.git] on branch develop) Remove /tmp/memo from OMEROWrapper (Fix #10836)

The /tmp/memo directory was still present on the one
testing server that the plate import was not working
on which led to plates not being imported. Moving the
directory away allowed plates to be imported. My guess
is that this will fix the issue.

comment:17 Changed 8 years ago by jean-marie burel <j.burel@…>

(In [2e3bcea06aa702d616dda7fc70cbfaee3dcae2cb/ome.git] on branch develop) Merge pull request #1208 from joshmoore/10836-tmp-memo

Remove /tmp/memo from OMEROWrapper (Fix #10836)

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.70467 sec.)

We're Hiring!