Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #1111 (closed)

Opened 13 years ago

Closed 9 years ago

Updating links doesn't always remove FK constraint

Reported by: jamoore Owned by: jamoore
Priority: critical Milestone: Cleanup
Component: General Version: 3.0-M1
Keywords: n.a. Cc: cxallan
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

In pseudocode:

   link = obtainLink();
   old_child = link.child;

   link.parent = new Something( link.parent.id, false );
   link.child = new Otherthing( );
   iupdate.saveObject(link);

   // The following *sometimes* throws a ValidationException
   // because the link still points at the old_child
   iupdate.deleteObject(old_child);

Change History (1)

comment:1 Changed 9 years ago by jmoore

  • Resolution set to invalid
  • Status changed from new to closed

I highly doubt this is still a problem, otherwise we would see these validation exceptions coming through. Closing without trying to reproduce something that happens "sometimes".

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.76987 sec.)

We're Hiring!