Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #11304 (new)

Opened 6 years ago

Last modified 4 years ago

Bug: omero admin diagnostics fails early

Reported by: cblackburn Owned by:
Priority: minor Milestone: FacilityManagers
Component: Deployment Version: n.a.
Keywords: n.a. Cc: jamoore, sbesson
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

I noticed this on a running OMERO 5 server (cls-repo-dev)

[omero@cls-repo-dev openmicroscopy]$ dist/bin/omero admin diagnostics
FATAL: Cannot access /home/omero/openmicroscopy/dist/var/nginx_tmp, a required file/directory for OMERO

Should diagnostics fail so early?

Change History (3)

comment:1 Changed 4 years ago by jamoore

  • Component changed from General to Deployment

Though a missing omero.data.dir doesn't fail so early, var/ still does:

# jamoore@joshuas-mbp:/opt/ome9$ chmod a-rwx dist/var
# jamoore@joshuas-mbp:/opt/ome9$ dist/bin/omero admin diagnostics
FATAL: Cannot access /opt/ome9/dist/var, a required file/directory for OMERO

comment:2 Changed 4 years ago by jamoore

  • Milestone set to Unscheduled

comment:3 Changed 4 years ago by jburel

  • Milestone changed from Unscheduled to FacilityManagers
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.92747 sec.)

We're Hiring!