Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #11378 (closed)

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

BUG: omero.cmd.SessionI Unknown servant type errors

Reported by: spli Owned by: jamoore
Priority: blocker Milestone: OMERO-4.4.9
Component: Services Version: 4.4.8
Keywords: n.a. Cc: jamoore, python-team@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: n.a.

Description

Blitz-0.log on develop (gretzky 5.0.0-beta1-171-3230530-ice33-b378) and dev_4_4 (howe 4.4.8-444-35b9ff3-ice33-b330) contains hundreds of omero.cmd.SessionI Unknown servant type errors.

2013-08-15 14:28:00,570 INFO  [                      omero.cmd.SessionI] (l.Server-0) cleanupSelf(ServiceFactoryI(session-4926d683-829f-4370-809e-d36e138223dc/43454470-7dcb-4dd8-aa72-9d521a686dd1)).
2013-08-15 14:28:00,570 ERROR [                      omero.cmd.SessionI] (l.Server-0) Unknown servant type: ome.services.blitz.impl.QueryI@b40e82
2013-08-15 14:28:00,570 DEBUG [                omero.util.ServantHolder] (l.Server-0) Removed omero.api._IQueryTie@8d4356dd from omero.util.ServantHolder@13b32b54 as 4926d683-829f-4370-809e-d36e138223dcomero.api.IQuery
2013-08-15 14:28:00,570 INFO  [                      omero.cmd.SessionI] (l.Server-0) Unregistered servant:43454470-7dcb-4dd8-aa72-9d521a686dd1/4926d683-829f-4370-809e-d36e138223dcomero.api.IQuery(omero.api._IQueryTie@8d4356dd)
2013-08-15 14:28:00,570 INFO  [                      omero.cmd.SessionI] (l.Server-0) Removed servant from adapter: 4926d683-829f-4370-809e-d36e138223dcomero.api.IQuery
2013-08-15 14:28:00,570 ERROR [                      omero.cmd.SessionI] (l.Server-0) Unknown servant type: ome.services.blitz.impl.ContainerI@4d22a0b0
2013-08-15 14:28:00,570 DEBUG [                omero.util.ServantHolder] (l.Server-0) Removed omero.api._IContainerTie@d9b1e90b from omero.util.ServantHolder@13b32b54 as 4926d683-829f-4370-809e-d36e138223dcomero.api.IContainer
2013-08-15 14:28:00,571 INFO  [                      omero.cmd.SessionI] (l.Server-0) Unregistered servant:43454470-7dcb-4dd8-aa72-9d521a686dd1/4926d683-829f-4370-809e-d36e138223dcomero.api.IContainer(omero.api._IContainerTie@d9b1e90b)
2013-08-15 14:28:00,571 INFO  [                      omero.cmd.SessionI] (l.Server-0) Removed servant from adapter: 4926d683-829f-4370-809e-d36e138223dcomero.api.IContainer
2013-08-15 14:28:00,571 ERROR [                      omero.cmd.SessionI] (l.Server-0) Unknown servant type: ome.services.blitz.impl.AdminI@1e5ecbc1
2013-08-15 14:28:00,571 DEBUG [                omero.util.ServantHolder] (l.Server-0) Removed omero.api._IAdminTie@aaee141c from omero.util.ServantHolder@13b32b54 as 4926d683-829f-4370-809e-d36e138223dcomero.api.IAdmin
2013-08-15 14:28:00,571 INFO  [                      omero.cmd.SessionI] (l.Server-0) Unregistered servant:43454470-7dcb-4dd8-aa72-9d521a686dd1/4926d683-829f-4370-809e-d36e138223dcomero.api.IAdmin(omero.api._IAdminTie@aaee141c)
2013-08-15 14:28:00,571 INFO  [                      omero.cmd.SessionI] (l.Server-0) Removed servant from adapter: 4926d683-829f-4370-809e-d36e138223dcomero.api.IAdmin

They seem to be generated when performing any activity in OMERO.web after logging in, however Insight doesn't seem to cause these ERRORs.

It looks like this might have been around for a while- there's an old log on Gretzky dated 2013-07-22 with these errors.

Change History (9)

comment:1 Changed 7 years ago by spli

  • Priority changed from minor to blocker

comment:2 Changed 7 years ago by atarkowska

This is cased by the decorator cleanup

> /Users/ola/OMERO/openmicroscopy/dist/lib/python/omero/clients.py(819)closeSession()
-> try:
(Pdb) 
> /Users/ola/OMERO/openmicroscopy/dist/lib/python/omero/clients.py(820)closeSession()
-> self.getRouter(oldIc).destroySession()
(Pdb) 
ConnectionLostException: exceptio...ror = 0
}
> /Users/ola/OMERO/openmicroscopy/dist/lib/python/omero/clients.py(820)closeSession()
-> self.getRouter(oldIc).destroySession()

is that really web specific?

Last edited 7 years ago by atarkowska (previous) (diff)

comment:3 Changed 7 years ago by spli

  • Cc python-team@… added; web-team@… removed
  • Component changed from Web to OmeroPy
  • Owner changed from web-team@… to python-team@…

Assigned to python-team.

comment:4 Changed 7 years ago by spli

test case

cli=omero.client('howe.openmicroscopy.org.uk')
sess=cli.createSession('user','password')
conn=omero.gateway.BlitzGateway(client_obj=cli)
list(conn.listGroups())
conn._closeSession() # Causes error in Blitz-0.log

comment:5 Changed 7 years ago by jamoore

  • Component changed from OmeroPy to Services
  • Owner changed from python-team@… to jamoore

Actually it's even easier:

import omero
cli=omero.client('localhost')
sess=cli.createSession('root','ome')
sess.getAdminService()
cli.__del__()

In other words, not gateway or even Python related. I would assume we're not seeing it elsewhere because of less usage.

Almost certainly caused by:

commit 73ca8be1e681badd79ef05b9060de2ec2d233a2b
Author: jmoore <josh@glencoesoftware.com>
Date:   Sun Jun 9 21:12:19 2013 +0200

    Refactor *Close into AbstractCloseableAmdServant (Fix #11074)
    
    Changing the signature of preClose and postClose in
    AbstractAmdServant to include an Ice.Current argument
    (See 94fca87e891185b6ca4256512ef16812396d29df) left
    ExporterI with an uncalled preClose method which in turn
    left temp files dangling.
    
    Adding `@Override` to the protected method would prevent
    such errors in the future, but this refactoring goes a
    step further and makes the methods abstract so that they
    must be implemented.

Fixing. Thanks for the tests all!

comment:6 Changed 7 years ago by jamoore

See also:

commit fc856a1bf7fc0305bbe9fd9439099d2ce5f8912b
Author: jmoore <josh@glencoesoftware.com>
Date:   Fri Jul 29 10:08:09 2011 +0200

    Refactor: omero.cmd package out of ome.services.blitz

comment:7 Changed 7 years ago by jamoore

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 7 years ago by jmoore <josh@…>

  • Remaining Time set to 0

(In [17f9f8ea8268d661289568a4353b6da3601ba68e/ome.git] on branch develop) Remove ERROR log on non-CloseableServant? (Fix #11378)

Since the refactoring the close methods out of
AbstractAmdServant and into CloseableServant,
an ERROR has been printed for each stateless
service.

comment:9 Changed 7 years ago by Josh Moore <josh@…>

(In [6d5d3995e9a6d059dd15ea8a024d0bc040756822/ome.git] on branch develop) Merge pull request #1401 from joshmoore/11378-closeable-servant

Remove ERROR log on non-CloseableServant? (Fix #11378)

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.192225 sec.)

We're Hiring!