Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #11665 (closed)

Opened 7 years ago

Closed 7 years ago

Bug: diagnostics misuses variable

Reported by: jamoore Owned by: sbesson
Priority: critical Milestone: 5.0.0-rc1
Component: OmeroPy Version: 4.4.9
Keywords: n.a. Cc: bpindelski, cblackburn, sbesson
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

OMERO data dir: '/repositories/OMERO-merge-develop-FS'    Exists? <function exists at 0x3bc65f0>    Is writable? True
OMERO temp dir: '/home/hudson/omero/tmp'    Exists? <function exists at 0x3bc65f0>    Is writable? True   (Size: 0)

Some minor change to diagnostics has led to corruption of the output. See above.

Change History (2)

comment:1 Changed 7 years ago by sbesson

  • Owner set to sbesson
  • Status changed from new to accepted

Caused by https://github.com/openmicroscopy/openmicroscopy/commit/8d40d7fc1b3cc3559c7d5757a5dbab8aa0ef41d8

commit 8d40d7fc1b3cc3559c7d5757a5dbab8aa0ef41d8
Author: Sebastien Besson <seb.besson@gmail.com>
Date:   Wed Oct 2 14:51:04 2013 +0100

    Fix flake8 output for CLI admin plugin

diff --git a/components/tools/OmeroPy/src/omero/plugins/admin.py b/components/tools/OmeroPy/src/omero/plugins/admin.py
index d1615c8..359dfe7 100755
--- a/components/tools/OmeroPy/src/omero/plugins/admin.py
+++ b/components/tools/OmeroPy/src/omero/plugins/admin.py
...
-            exists = os.path.exists(dir_path)
 -            is_writable = os.access(dir_path, os.R_OK|os.W_OK)
 -            if dir_size and exists:
 +            dir_path_exists = os.path.exists(dir_path)
 +            is_writable = os.access(dir_path, os.R_OK | os.W_OK)
 +            if dir_size and dir_path_exists:
                  dir_size = self.getdirsize(omero_temp_dir)
                  dir_size = "   (Size: %s)" % dir_size
 -            self.ctx.out("OMERO %s dir: '%s'\tExists? %s\tIs writable? %s%s" % \
 -                (dir_name, dir_path, exists, is_writable, dir_size))
 +            self.ctx.out("OMERO %s dir: '%s'\tExists? %s\tIs writable? %s%s" %
 +                         (dir_name, dir_path, exists, is_writable, dir_size))

Exists was renamed because the variable name was conflicting with the exists() function defined somewhere else in the file but the name change was not propagated everywhere.

comment:2 Changed 7 years ago by sbesson

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.116290 sec.)

We're Hiring!