Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #11667 (closed)

Opened 7 years ago

Closed 7 years ago

BUG: LockTimeout: exception ::omero::LockTimeout

Reported by: rkferguson Owned by: web-team@…
Priority: critical Milestone: 5.0.0-rc1
Component: Web Version: 5.0.0-beta1
Keywords: UTPhase1 Cc: pwalczysko
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: OMERO 5 Beta 2 (1)

Description

upgrade testing Phase I

Windows 8 IE 10
https://omero4-demo.openmicroscopy.org:1443/webclient/login/?url=%2Fwebclient%2F
user-10 read-write-1

archivedv > CFPNEAT01_R3D.dv

Clicked on Acquisition tag
Progress icon and then this trace-back error message.
Reproducible with other DVs in the same dataset

{{
Traceback (most recent call last):

File "/opt/hudson/workspace/OMERO-merge-develop-FS/src/dist/lib/python/django/core/handlers/base.py", line 111, in get_response

response = callback(request, *callback_args, callback_kwargs)

File "/opt/hudson/workspace/OMERO-merge-develop-FS/src/dist/lib/python/omeroweb/decorators.py", line 377, in wrapped

retval = f(request, *args, kwargs)

File "/opt/hudson/workspace/OMERO-merge-develop-FS/src/dist/lib/python/omeroweb/decorators.py", line 414, in wrapper

context = f(request, *args, kwargs)

File "/opt/hudson/workspace/OMERO-merge-develop-FS/src/dist/lib/python/omeroweb/webclient/views.py", line 926, in load_metadata_acquisition

manager.originalMetadata()

File "/opt/hudson/workspace/OMERO-merge-develop-FS/src/dist/lib/python/omeroweb/webclient/controller/container.py", line 254, in originalMetadata

om = self.image.loadOriginalMetadata()

File "/opt/hudson/workspace/OMERO-merge-develop-FS/src/dist/lib/python/omero/gateway/init.py", line 6270, in loadOriginalMetadata

cb = self._conn._waitOnCmd(handle)

File "/opt/hudson/workspace/OMERO-merge-develop-FS/src/dist/lib/python/omero/gateway/init.py", line 3366, in _waitOnCmd

callback.loop(loops, ms) # Throw LockTimeout?

File "/opt/hudson/workspace/OMERO-merge-develop-FS/src/dist/lib/python/omero/callbacks.py", line 321, in loop

5000L, int(waited))

LockTimeout?: exception ::omero::LockTimeout?
{

serverStackTrace = None
serverExceptionClass = None
message = Command unfinished after 5.0 seconds
backOff = 5000
seconds = 5

}

<WSGIRequest
GET:<QueryDict: {}>,
POST:<QueryDict: {}>,
COOKIES:{'sessionid': 'cc0f4512536e4a69472f345ccf0759ea'},
META:{'CONTENT_LENGTH': ,

'CONTENT_TYPE': ,
'HTTPS': 'on',
'HTTP_ACCEPT': 'text/html, */*; q=0.01',
'HTTP_ACCEPT_ENCODING': 'gzip, deflate',
'HTTP_ACCEPT_LANGUAGE': 'en-US',
'HTTP_CONNECTION': 'Keep-Alive',
'HTTP_COOKIE': 'sessionid=cc0f4512536e4a69472f345ccf0759ea',
'HTTP_DNT': '1',
'HTTP_HOST': 'omero4-demo.openmicroscopy.org:1443',
'HTTP_REFERER': 'https://omero4-demo.openmicroscopy.org:1443/webclient/userdata/',
'HTTP_USER_AGENT': 'Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)',
'HTTP_X_REQUESTED_WITH': 'XMLHttpRequest',
'PATH_INFO': u'/webclient/metadata_acquisition/image/9711/',
'QUERY_STRING':
,
'REQUEST_METHOD': 'GET',
'SCRIPT_NAME': u,
'SERVER_NAME': 'ome-c6100-3',
'SERVER_PORT': '1443',
'SERVER_PROTOCOL': 'HTTP/1.1',
'wsgi.errors': <flup.server.fcgi_base.TeeOutputStream? object at 0x7725ed0>,
'wsgi.input': <flup.server.fcgi_base.InputStream? object at 0x7725490>,
'wsgi.multiprocess': True,
'wsgi.multithread': False,
'wsgi.run_once': False,
'wsgi.url_scheme': 'https',
'wsgi.version': (1, 0)}>

}}

Change History (2)

comment:1 Changed 7 years ago by rkferguson

Subsequently resolved itself - able to view acquisition data for these files about 15 minutes later - and then happened again - so definitely intermittent repeating error.

Last edited 7 years ago by rkferguson (previous) (diff)

comment:2 Changed 7 years ago by wmoore

  • Resolution set to invalid
  • Status changed from new to closed

I think the web just timed out because the server was under heavy load (as discussed in devteam)

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.511228 sec.)

We're Hiring!