Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #11706 (new)

Opened 6 years ago

Last modified 4 years ago

BUG: Thumb - full viewer mismatch

Reported by: pwalczysko Owned by:
Priority: major Milestone: Rendering
Component: General Version: 4.4.9
Keywords: BACKPORT-4.4 Cc: fs@…, ux@…, mlinkert
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

eported during the Phase I of upgrade testing by @bpindelski (line 12 of the gdoc https://docs.google.com/spreadsheet/ccc?key=0AoKiTAl8UOxndGt5bm5mOWl4M1lMc1NkQzVVRW5CZGc&usp=drive_web#gid=13) This was performed on omero4-demo server with develop database which was upgraded from dev_4_4 database (originally from Howe). The images were all the original dev_4_4 upgraded images, no new FS imports were in the DB at that point. bpindelski was viewing big images.

Wrong thumbnail shown for image in both Insight and Web.

OS X 10.8.5, Chrome

Attachments (3)

thumbnail.png (287.8 KB) - added by pwalczysko 6 years ago.
Screen Shot 2013-11-15 at 14.45.19.png (511.5 KB) - added by pwalczysko 6 years ago.
Howe reimport.png (378.1 KB) - added by pwalczysko 6 years ago.

Download all attachments as: .zip

Change History (20)

Changed 6 years ago by pwalczysko

comment:1 Changed 6 years ago by pwalczysko

I can repeat this one. user-2, private-1 on omero4 server, go to ArchivedBig? Images dataset and click onto the thumbnail which is hightlighted on the attached screenshot. Mismatching full viewer pops up. I do not have selected the 8kx8k.jpf image in the first row of the central pane (not sure how bpindelski managed that).

Changed 6 years ago by pwalczysko

comment:2 Changed 6 years ago by pwalczysko

This mismatch is present on Howe as well - nothing to do with DB upgrade.

comment:3 Changed 6 years ago by pwalczysko

  • Priority changed from critical to major

comment:4 Changed 6 years ago by jamoore

Petr & Blazej: I'm not understanding the steps to reproduce. Does it always happen for the same file? If so, which file?

comment:5 Changed 6 years ago by pwalczysko

Yes it does. It is test_images_good/leica-scn/mihaela/UCLAD_0000000280_2011-02-10 13_32_55Z.scn [UCLAD_0000000927 (R4)].

comment:6 Changed 6 years ago by wmoore

Very strange - If I view the thumbnail at size 103 or smaller, E.g. https://omero4-demo.openmicroscopy.org:1443/webclient/render_thumbnail/size/103/10/ it appears as above (wrong thumbnail) but if I go size 104 or bigger, E.g. https://omero4-demo.openmicroscopy.org:1443/webclient/render_thumbnail/size/104/10/ it appears normal. Need to import locally to play more...

comment:7 Changed 6 years ago by jamoore

  • Owner set to pwalczysko

Petr: could you try to reproduce from a fresh import? My current assumption is that this is corrupted data/thumbnails on howe.

comment:8 Changed 6 years ago by pwalczysko

Re-imported the image to Gretzky and Howe. On Gretzky, there is no problem with any thumbnail mismatch. Howe - still waiting for all the thumbs to appear (user-6. read-only-1, dataset mihaela)

Last edited 6 years ago by pwalczysko (previous) (diff)

comment:9 Changed 6 years ago by pwalczysko

Re-import to Howe turned up. The image is erroneous in the sense of this ticket. See screenshot.

Changed 6 years ago by pwalczysko

comment:10 Changed 6 years ago by mlinkert

  • Milestone changed from 5.0.0-beta2 to OMERO-4.4.10
  • Sprint OMERO 5 Beta 2 (1) deleted
  • Version changed from 5.0.0-beta1 to 4.4.9

Updating milestone and version given that only howe shows the problem.

comment:11 Changed 6 years ago by mlinkert

In testing locally, this appears to be a problem with how the thumbnail for 'UCLAD_0000000927 (R4)' is generated. When opened in other software, the JPEG thumbnail file also looks incorrect. Based upon the way in which the thumbnail is distorted, I would guess that the thumbnail image that is generated is either one pixel wider or one pixel narrower than the recorded thumbnail width. I don't know the thumbnailing logic well enough to be able to debug further without some assistance though.

What's shown in the full viewer is correct, and matches up with the full viewer and thumbnails for other images in the same file.

comment:12 Changed 6 years ago by pwalczysko

Not sure why I am an owner of this. Passing.

comment:13 Changed 6 years ago by pwalczysko

  • Owner pwalczysko deleted

comment:14 Changed 4 years ago by jamoore

  • Milestone changed from 5.1.2 to 5.1.3

comment:15 Changed 4 years ago by jamoore

  • Milestone changed from 5.1.4 to OMERO-5.1.4

Splitting 5.1.4 due to milestone decoupling

comment:16 Changed 4 years ago by jamoore

  • Milestone changed from 5.x to Unscheduled

comment:17 Changed 4 years ago by jburel

  • Milestone changed from Unscheduled to Rendering
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.193148 sec.)

We're Hiring!