Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #11754 (closed)

Opened 8 years ago

Closed 8 years ago

BUG: Connecton problems

Reported by: pwalczysko Owned by: jburel
Priority: critical Milestone: 5.0.0-rc1
Component: Insight Version: 4.4.9
Keywords: n.a. Cc: ux@…, jamoore, cblackburn
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: OMERO 5 Beta 2 (1)

Description

Login to Howe as user-6, put on Group display, try to delete plates of all users, first deletion of 3-4 plates started, then went on and tried to delete some screens.
Possibly connected to recent work on Connection problems ?

Got

java.lang.Exception: org.openmicroscopy.shoola.env.data.DSOutOfServiceException: Failed to create connector
	at org.openmicroscopy.shoola.env.data.OMEROGateway.getConnector(OMEROGateway.java:1518)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.loadContainerHierarchy(OMEROGateway.java:2288)
	at org.openmicroscopy.shoola.env.data.OmeroDataServiceImpl.loadContainerHierarchy(OmeroDataServiceImpl.java:225)
	at org.openmicroscopy.shoola.env.data.views.calls.DMLoader$1.doCall(DMLoader.java:90)
	at org.openmicroscopy.shoola.env.data.views.BatchCall.doStep(BatchCall.java:144)
	at org.openmicroscopy.shoola.util.concur.tasks.CompositeTask.doStep(CompositeTask.java:226)
	at org.openmicroscopy.shoola.env.data.views.CompositeBatchCall.doStep(CompositeBatchCall.java:126)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.exec(ExecCommand.java:165)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.run(ExecCommand.java:276)
	at org.openmicroscopy.shoola.util.concur.tasks.AsyncProcessor$Runner.run(AsyncProcessor.java:91)
	at java.lang.Thread.run(Thread.java:680)
Caused by: Glacier2.CannotCreateSessionException
    reason = " Wrapped Exception: (org.springframework.dao.DataAccessResourceFailureException):
              CallableStatementCallback; SQL [{? = call _prepare_session(?, ?, ?)}]; ERROR: could not extend relation base/596583/615299: No space left on device
                Hint: Check free disk space.
                Where: SQL statement "INSERT INTO _current_session VALUES ( $1 ,  $2 ,  $3 )"
              PL/pgSQL function "_prepare_session" line 8 at SQL statement; nested exception is org.postgresql.util.PSQLException: ERROR: could not extend relation base/596583/615299: No space left on device
                Hint: Check free disk space.
                Where: SQL statement "INSERT INTO _current_session VALUES ( $1 ,  $2 ,  $3 )"
              PL/pgSQL function "_prepare_session" line 8 at SQL statement"
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
	at java.lang.Class.newInstance0(Class.java:357)
	at java.lang.Class.newInstance(Class.java:310)
	at IceInternal.BasicStream$DynamicUserExceptionFactory.createAndThrow(BasicStream.java:2243)
	at IceInternal.BasicStream.throwException(BasicStream.java:1632)
	at IceInternal.Outgoing.throwUserException(Outgoing.java:442)
	at Glacier2._RouterDelM.createSession(_RouterDelM.java:42)
	at Glacier2.RouterPrxHelper.createSession(RouterPrxHelper.java:51)
	at Glacier2.RouterPrxHelper.createSession(RouterPrxHelper.java:29)
	at omero.client.createSession(client.java:672)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.getConnector(OMEROGateway.java:1508)
	... 10 more

	at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.showErrorDialog(UserNotifierImpl.java:189)
	at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.notifyError(UserNotifierImpl.java:287)
	at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.notifyError(UserNotifierImpl.java:257)
	at org.openmicroscopy.shoola.agents.treeviewer.DataBrowserLoader.handleException(DataBrowserLoader.java:148)
	at org.openmicroscopy.shoola.env.data.events.DSCallAdapter.eventFired(DSCallAdapter.java:84)
	at org.openmicroscopy.shoola.env.data.views.BatchCallMonitor$1.run(BatchCallMonitor.java:124)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:715)
	at java.awt.EventQueue.access$400(EventQueue.java:82)
	at java.awt.EventQueue$2.run(EventQueue.java:676)
	at java.awt.EventQueue$2.run(EventQueue.java:674)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:86)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:685)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Change History (7)

comment:1 Changed 8 years ago by pwalczysko

Actually the error appears exactly when I try to expand the node of the next group after being done with deletions in the previous group.

comment:2 Changed 8 years ago by pwalczysko

This situation might be connected to the fact that Howe ran out of space just now- but still

comment:3 Changed 8 years ago by jburel

I have done some work, I will open a PR tomorrow. Nothing currently included in the build.

comment:4 Changed 8 years ago by jamoore

This is definitely an issue of howe not having any more space, and there's nothing that could be done here other than throw the CannotCreateSessionException. If a different string in the reason field would have helped, Jean-marie, let me know.

comment:5 Changed 8 years ago by jburel

The error is fine. Just was not handled. Added support as part of the connection work.

comment:6 Changed 8 years ago by jburel

  • Sprint set to OMERO 5 Beta 2 (1)
  • Status changed from new to accepted

comment:7 Changed 8 years ago by jburel

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.68026 sec.)

We're Hiring!