Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #11830 (closed)

Opened 7 years ago

Closed 7 years ago

Bug: Insight debugging in Eclipse throws exception

Reported by: bpindelski Owned by: jburel
Priority: minor Milestone: 5.1.0
Component: Insight Version: 5.0.0-beta2-RC3
Keywords: n.a. Cc: mlinkert
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

Before https://github.com/openmicroscopy/bioformats/pull/790 got merged into BF and the submodule pointer updated in Omero, debugging Insight in Eclipse was simple - start debugger and after a couple of seconds see the login window.

After the PR, the debugger is now stopping during the startup phase with a FileNotFoundException? for the following files:

  • openmicroscopy/lib/cache/bf-deps/netcdf/jars/jcl-over-slf4j-1.7.5.jar
  • openmicroscopy/lib/cache/bf-deps/netcdf/jars/ehcache-core-2.6.2.jar

This requires the developer to step through those exceptions before the login window appears. This ticket requires investigation why the bootstrap process of Insight requires those specific JARs (which don't exist on the file system).

Change History (1)

comment:1 Changed 7 years ago by bpindelski

  • Resolution set to duplicate
  • Status changed from new to closed

Closing. Duplicate of http://trac.openmicroscopy.org.uk/ome/ticket/11829. Trac misbehaving.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.79793 sec.)

We're Hiring!