Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #11839 (closed)

Opened 10 years ago

Closed 10 years ago

Bug: Shares not visible to Members

Reported by: wmoore Owned by: bpindelski
Priority: major Milestone: 5.1.0
Component: Web Version: 4.4.9
Keywords: n.a. Cc: web-team@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

If I create a share (E.g. in a private group) and add another member of the server (also member of group) - they login and go to "Public" but can't see the share listed.

Change History (4)

comment:1 Changed 10 years ago by wmoore

  • Owner changed from wmoore to jamoore

This is due to a failure of the Share service getMemberShares(), as confirmed by failing of the corresponding test"

$ cd OmeroPy
$ ./setup.py test -s test/integration/test_ishare.py -k test2327
...
        l = share2.getMemberShares(False)
>       assert 1 ==  len(l)
E       assert 1 == 0
E        +  where 0 = len([])

test/integration/test_ishare.py:535: AssertionError
====== 25 tests deselected by '-ktest2327' =====
====== 1 failed, 25 deselected in 1.13 seconds ======

NB: comment out the decorator @pytest.mark.xfail(reason="See ticket #11537") if you want to see the full output.

comment:2 Changed 10 years ago by bpindelski

  • Owner changed from jamoore to bpindelski
  • Status changed from new to accepted

comment:3 Changed 10 years ago by bpindelski

Once the (rebased-onto-develop) PR (https://github.com/openmicroscopy/openmicroscopy/pull/2664) is merged, this can be closed.

comment:4 Changed 10 years ago by bpindelski

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.70710 sec.)

We're Hiring!