Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #12144 (closed)

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

Bug : newer .lif files fail to initialize

Reported by: bramalingam Owned by: mlinkert
Priority: major Milestone: 5.0.6
Component: Bio-Formats Version: 5.0.0
Keywords: n.a. Cc: r.a.hoebe@…, e.mackay@…, astout@…, mendelsm@…, rebecca.richardson@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: n.a.

Description (last modified by mlinkert)

Location.mapFile: embedded-stream.raw -> null

FILE_EXCEPTION: /ome/data_repo/from_Biozentrum_Basel/Charles/SP5/01-31hpi-Experiment.lif

loci.formats.FormatException: Invalid Memory Block: found magic bytes 0, expected 112

        at loci.formats.in.LIFReader.initFile(LIFReader.java:416)

        at loci.formats.FormatReader.setId(FormatReader.java:1319)

        at loci.formats.ImageReader.setId(ImageReader.java:757)

        at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:573)

        at loci.formats.ChannelFiller.setId(ChannelFiller.java:263)

        at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:573)

        at loci.formats.ChannelSeparator.setId(ChannelSeparator.java:274)

        at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:573)

        at loci.formats.Memoizer.setId(Memoizer.java:471)

        at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:573)

        at ome.formats.importer.ImportCandidates.singleFile(ImportCandidates.java:414)

        at ome.formats.importer.ImportCandidates.handleFile(ImportCandidates.java:595)

        at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:367)

        at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:335)

        at ome.formats.importer.ImportCandidates.execute(ImportCandidates.java:368)

        at ome.formats.importer.ImportCandidates.<init>(ImportCandidates.java:229)

SCANNING: Depth:0 Num:    2 Tot:    2 File: asel/Charles/SP5

2 file(s) parsed into 0 group(s) with 1 call(s) to setId in 68ms. (77ms total) [0 unknowns]

Change History (14)

comment:1 Changed 6 years ago by mlinkert

  • Component changed from General to Bio-Formats
  • Priority changed from minor to major
  • Summary changed from Bug : bug in Bio-Formats with LIF file to Bug : newer .lif files fail to initialize

comment:2 Changed 6 years ago by mlinkert

  • Description modified (diff)

comment:3 Changed 5 years ago by mlinkert

  • Milestone changed from Unscheduled to 5.1.0-m1

comment:4 Changed 5 years ago by mlinkert

  • Milestone changed from 5.1.0-m1 to 5.0.4

comment:5 Changed 5 years ago by mlinkert

See also datasets in leica-lif/fabrice/new/ and leica-lif/ron/. As far as I can tell, the last block has a 0 identifier, and is then padded with 0s (though it could also be that the length for the last "real" block needs adjusting).

comment:6 Changed 5 years ago by mlinkert

  • Cc r.a.hoebe@… added

comment:7 Changed 5 years ago by mlinkert

  • Cc e.mackay@… added

#12507 was a duplicate of this.

comment:9 Changed 5 years ago by crueden-x

See also http://fiji.sc/bugzilla/show_bug.cgi?id=911, which includes a small (~2.6MB) sample dataset attachment.

comment:10 Changed 5 years ago by crueden-x

  • Cc astout@… added

comment:11 Changed 5 years ago by mlinkert

  • Cc mendelsm@… added

comment:12 Changed 5 years ago by mlinkert

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with: https://github.com/openmicroscopy/bioformats/pull/1382

New builds containing this fix are not yet available.

comment:13 Changed 5 years ago by mtbcarroll

  • Cc rebecca.richardson@… added

comment:14 Changed 5 years ago by Melissa Linkert <melissa@…>

  • Remaining Time set to 0

(In [d2bd3e20e05a1c37a84c524da4075aabf6c1141f/bioformats.git] on branch develop) Leica LIF: fix support for new files with 0 padding

Fixes #12144

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.258720 sec.)

We're Hiring!