Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #12343 (closed)

Opened 7 years ago

Closed 7 years ago

BUG: Search image ID

Reported by: pwalczysko Owned by: dlindner
Priority: major Milestone: 5.0.3
Component: Insight Version: 5.0.2
Keywords: n.a. Cc: ux@…, sbesson, jrswedlow
Resources: n.a. Referenced By: https://trello.com/c/NDjNwZnm/52-bug-search-5-0-3
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

On dogfish server, the Image ID search fails in Insight.

Login as pwalczysko and search for image ID 99501 which is in data_repo group under user Joshua Moore in Orphaned images.

The search for IDs on gretzky works fine, even when they belong to someone else and in Orphaned folder works fine on Gretzky in Insight.

Note also, that the same search on dogfish for the same image ID 99501 works fine, so it is improbable this is an indexer problem.

Dogfish should have updated enough version of 5.0.1 on it for the search PRs to be in.

The only difference between gretzky and dogfish I can see now is that dogfish has ldap and gretzky does not (but maybe this is not important).

Attachments (3)

Screen Shot 2014-05-29 at 18.04.47.png (73.6 KB) - added by pwalczysko 7 years ago.
Screen Shot 2014-05-29 at 18.02.44.png (97.9 KB) - added by pwalczysko 7 years ago.
Screen Shot 2014-05-29 at 18.02.18.png (31.1 KB) - added by pwalczysko 7 years ago.

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by pwalczysko

Changed 7 years ago by pwalczysko

Changed 7 years ago by pwalczysko

comment:1 Changed 7 years ago by pwalczysko

Note that also @jrswedlow had the same experience with not being able to find the image, when logged in as himself -> to repeat the bug, you can login to dogfish as yourself

comment:2 Changed 7 years ago by pwalczysko

Further investigation: I seem not to be able to find anything in the data_repo group in Insight (unlike Web). This bug is not specific for search for ID, rather maybe for LDAP ?

comment:3 Changed 7 years ago by pwalczysko

  • Cc jrswedlow added

comment:4 Changed 7 years ago by jburel

the reason it works for web and not insight is due to the fact that web directly search in the DB and does not use lucene (i.e. id search key)
dogfish is currently very far behind (10% done at the moment) so the search by id will not work unless we directly search in DB.

comment:5 Changed 7 years ago by jamoore

comment:6 Changed 7 years ago by jburel

  • Owner changed from jburel to dlindner

comment:7 Changed 7 years ago by jburel

Decision:
insight: Search by ID. Query tDB.
behaviour: if number + text then treat as text.

see https://docs.google.com/document/d/1SzCSZH1IQOKiC_aBjPhe3bFWvzW06j1dlYFWPlyActQ/edit

comment:8 Changed 7 years ago by dlindner

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.69282 sec.)

We're Hiring!