Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #12350 (new)

Opened 5 years ago

Last modified 4 years ago

RFE: Cannot find search results

Reported by: pwalczysko Owned by: dlindner
Priority: critical Milestone: Unscheduled
Component: Insight Version: 5.0.2
Keywords: n.a. Cc: ux@…
Resources: n.a. Referenced By: https://trello.com/c/NDjNwZnm/52-bug-search-5-0-3
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

In Insight, after a successful search, I can click onto the images found in Search Results and open them in Full Viewer, but there is no link to lead me to where the image actually is in the Project/Dataset? structure.
This is better in Web, where there is a "Browse" link next to each search result which brings you to the image in tree.

Change History (24)

comment:1 Changed 5 years ago by jamoore

comment:2 Changed 5 years ago by jburel

  • Owner changed from jburel to dlindner

comment:3 Changed 5 years ago by jburel

I discussed the problem with dominik. It is similar to the one we have for the importer (browse link). We only currently scan what is displayed using a visitor. So if the element is not displayed in the tree it will not work
We can certainly fix that but it could take some time. Few cases to handle: object in current but not displayed, object in a group or owned by a user currently not displayed.

comment:4 Changed 5 years ago by pwalczysko

I think this would be a case for some quick-solution if the above mentioned work should take too long for 5.0.3 - maybe just some way to tell the user the containing Project/Dataset/Screen? ? The problem I am having there is that atm although I have plenty of Search results, I still do not know where they actually are -> not really found anything.

comment:5 Changed 5 years ago by dlindner

This seems to be a bigger task, probably not doable for 5.0.3. Therefore the "Browse" button for Datasets and Projects will be disabled, but Images have a "View" Button which opens the selected image in the full viewer. And as the MetadataViewer? now works for search results, you can find out about the exact location of the selected search result via the information provided there.

comment:6 Changed 5 years ago by dlindner

Browse button for Projects/Datasets? now works. Situation is now as follows:
Image search result: View -> Opens in full image viewer (you can still find out the location via MetadataViewer? shown after selection on the right hand side)
Project/Dataset? search result: Browse -> Will open the Project/Dataset? in the TreeViewer?

comment:7 Changed 5 years ago by dlindner

Had to disable the Browse button again, this is much too error-prone. Can't fix for 5.0.3.

comment:8 Changed 5 years ago by dlindner

  • Milestone changed from 5.0.3 to 5.0.4
  • Priority changed from critical to major

Changing to 5.0.4; Trello card https://trello.com/c/NDjNwZnm/52-bug-search-5-0-3 already updated accordingly.

comment:9 Changed 5 years ago by pwalczysko

  • Cc changed from ux@openmicroscopy.org.uk, to ux@openmicroscopy.org.uk

In couple of instances of me using the Search functionality (which works really nicely now) in Insight, I have following workflow problem:

  • NO IDEA where the result is located, there is absolutely no indication about containing Dataset, Project, Screen or anything in the UI

I had to forget couple of times the Search and go via tickets (or go via Web) to truly locate the found image.
This really cripples the Search functionality for the user.

In discussion with dlindner, I think we might go for a compromise solution: Add at least some (non-clickable) info about where the found entity is contained.
Dom suggests tooltip would be the fastest - far from optimal, but MUCH better than nothing -> which is what we have atm unfortunately.
We moved away from "Located in" for purity / alignment with Web reason, but as the true solution here is not easy to do, I think we should not cripple the Search functionality like this.
Maybe we could implement the tooltip for 5.1 ?

comment:10 Changed 5 years ago by pwalczysko

  • Priority changed from major to critical

comment:11 Changed 5 years ago by pwalczysko

Correction: We do have the Show Location menu option in the top menu hidden under the "path" icon. Quite bad though that both me and Dom forgot about its existence. How can a user find it then... (?)

comment:12 Changed 5 years ago by pwalczysko

After discussion with mporter.

  • mporter also has no idea that the new menu item is under the "semicolon & slash" icon
  • would never click onto it
  • is still looking for the "Located in" at the bottom of the right-hand pane

His suggestion:

  • instead of teh View button in the last column (in his opinion useless butoon) of the Results table, have a text saying "Dataset such-and-such" or "Project x and Dataset y" or "Screen z and Plate g"]
  • mporter claims that "not having the path to the found image is the most annoying thing in Search"

I think even running danger of slight non-sync between Insight and Web, these suggestion would do much to let people to find their images.
Nobody will click on a "colon and slash" icon.

comment:13 Changed 5 years ago by jburel

We need to see down asap to discuss possible changes.
Some scoping required before we start adjusting UI.

comment:14 Changed 5 years ago by dlindner

I re-enabled the 'Located in' pane in the metadata panel in PR https://github.com/openmicroscopy/openmicroscopy/pull/3484 Sufficient to close this ticket and add an RFE to the trello board? Or push the ticket to 5.1.1?

comment:15 Changed 5 years ago by pwalczysko

I would suggest to push the ticket. Although this is good for 5.1.0 and has improved in some way by showing the path, it is still a major pain (the missing Browse button on Search results.)

comment:16 Changed 5 years ago by jamoore

  • Milestone changed from 5.1.0 to 5.1.1

comment:17 Changed 5 years ago by jburel

The browse button has already a ticket (browse from importer) so we should close this one and update the other ticket

comment:18 Changed 5 years ago by dlindner

  • Milestone changed from 5.1.1 to 5.1.2

comment:19 Changed 5 years ago by dlindner

  • Milestone changed from 5.1.2 to 5.1.3

comment:20 Changed 4 years ago by jamoore

  • Milestone changed from 5.1.4 to OMERO-5.1.4

Splitting 5.1.4 due to milestone decoupling

comment:21 Changed 4 years ago by dlindner

  • Milestone changed from OMERO-5.1.4 to OMERO-5.2.0

comment:22 Changed 4 years ago by dlindner

  • Milestone changed from OMERO-5.2.0 to OMERO-5.2.1

Still no feasible solution for this.

comment:23 Changed 4 years ago by dlindner

  • Milestone OMERO-5.2.1 deleted

comment:24 Changed 4 years ago by jamoore

  • Milestone set to Unscheduled
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.288316 sec.)

We're Hiring!