Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #12432 (new)

Opened 5 years ago

Last modified 4 years ago

Bug: "bin/omero load -k" doesn't exit to shell in certain cases

Reported by: bpindelski Owned by:
Priority: major Milestone: Unscheduled
Component: Client Version: 5.0.2
Keywords: n.a. Cc: jamoore
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

When testing https://github.com/openmicroscopy/openmicroscopy/pull/2699, it has been discovered that there is one corner case where exiting to the shell from bin/omero load <script> doesn't happen instantly.

To reproduce:

  1. Successfully run a script using bin/omero load <script>
  2. Run the script for the second time (using --keep-going this time),
  3. When prompted to log in to OMERO, hit Cmd+C - you should get a message about Ignoring error: ...
  4. It's impossible to go back to the shell instantly - one has to keep bashing Cmd+C to skip all the lines of the script!

This might be a bigger task, as per sbesson's comments on the PR.

Change History (2)

comment:1 Changed 5 years ago by jamoore

  • Milestone changed from 5.1.0 to 5.x

comment:2 Changed 4 years ago by jamoore

  • Milestone changed from 5.x to Unscheduled
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.116081 sec.)

We're Hiring!