Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #12434 (closed)

Opened 7 years ago

Closed 7 years ago

BUG: Large image Preview tab uncaught NullPointerException

Reported by: rkferguson Owned by: jburel
Priority: blocker Milestone: 5.0.3
Component: Insight Version: 5.1.0-m0
Keywords: n.a. Cc:
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description (last modified by rkferguson)

Tested https://github.com/openmicroscopy/openmicroscopy/pull/2722 using OMERO.insight-5.1.0-m0.3-1135-b05a5f6-ice35-b208-win trout user-6 read-annotate-1.

Imported 3 jpegs - 2kx2k, 4kx4k, 8kx8k.
After import complete, in main viewer, thumbnail for 8kx8k still generating, but for others in centre pane.

Selected 2kx2k - then Preview tab - thumbnail appears in metadata viewer as expected

Selected 4kx4k in centre pane - Preview tab appeared greyed out

Without delaying clicked back on 2kx2k in centre pane

Crashed with following error message.

Replicated this in Mac version after 8kx8k thumbnail had finished generating.

Same crash when clicked away from 4kx4k and 8kx8k Preview tab before display complete.

It appears that if you wait for the Preview tab to load completely there is not an issue, but as the delay for the Preview pane to appear for 4kx4k is 5 seconds 8kx8k is 15 seconds (2kx2k 2 seconds) - it is very likely that the user will click away.

Select 2kx2k in the centre pane after 8kx8k has been viewed and there is also a delay of about 5 seconds before 2kx2k appears in the Preview tab.

This is also likely to affect 5.0.3 where this was rebased from.

Screenshot attached.

java.lang.Exception: Abnormal termination due to an uncaught exception.
java.lang.NullPointerException
    at org.openmicroscopy.shoola.agents.metadata.view.MetadataViewerUI.createViewedByItems(MetadataViewerUI.java:232)
    at org.openmicroscopy.shoola.agents.metadata.view.MetadataViewerComponent.setViewedBy(MetadataViewerComponent.java:1092)
    at org.openmicroscopy.shoola.agents.metadata.RenderingSettingsLoader.handleResult(RenderingSettingsLoader.java:117)
    at org.openmicroscopy.shoola.env.data.events.DSCallAdapter.eventFired(DSCallAdapter.java:90)
    at org.openmicroscopy.shoola.env.data.views.BatchCallMonitor$1.run(BatchCallMonitor.java:124)
    at java.awt.event.InvocationEvent.dispatch(Unknown Source)
    at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
    at java.awt.EventQueue.access$200(Unknown Source)
    at java.awt.EventQueue$3.run(Unknown Source)
    at java.awt.EventQueue$3.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
    at java.awt.EventQueue.dispatchEvent(Unknown Source)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.run(Unknown Source)
Abnormal termination due to an uncaught exception.
java.lang.NullPointerException
    at org.openmicroscopy.shoola.agents.metadata.view.MetadataViewerUI.createViewedByItems(MetadataViewerUI.java:232)
    at org.openmicroscopy.shoola.agents.metadata.view.MetadataViewerComponent.setViewedBy(MetadataViewerComponent.java:1092)
    at org.openmicroscopy.shoola.agents.metadata.RenderingSettingsLoader.handleResult(RenderingSettingsLoader.java:117)
    at org.openmicroscopy.shoola.env.data.events.DSCallAdapter.eventFired(DSCallAdapter.java:90)
    at org.openmicroscopy.shoola.env.data.views.BatchCallMonitor$1.run(BatchCallMonitor.java:124)
    at java.awt.event.InvocationEvent.dispatch(Unknown Source)
    at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
    at java.awt.EventQueue.access$200(Unknown Source)
    at java.awt.EventQueue$3.run(Unknown Source)
    at java.awt.EventQueue$3.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
    at java.awt.EventQueue.dispatchEvent(Unknown Source)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.run(Unknown Source)
Exception in thread "AWT-EventQueue-0"

    at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.showErrorDialog(UserNotifierImpl.java:191)
    at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.notifyError(UserNotifierImpl.java:291)
    at org.openmicroscopy.shoola.env.AbnormalExitHandler.doTermination(AbnormalExitHandler.java:147)
    at org.openmicroscopy.shoola.env.AbnormalExitHandler.terminate(AbnormalExitHandler.java:85)
    at org.openmicroscopy.shoola.env.RootThreadGroup.uncaughtException(RootThreadGroup.java:69)
    at java.awt.EventDispatchThread.processException(Unknown Source)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.run(Unknown Source)}}}

Attachments (1)

user-6 user-6 connected to trout.openmicroscopy.org.jpg (143.7 KB) - added by rkferguson 7 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 7 years ago by rkferguson

  • Description modified (diff)

comment:2 Changed 7 years ago by rkferguson

  • Description modified (diff)

comment:3 Changed 7 years ago by rkferguson

@jburel - confirmed that 5.0.3 is also affected - same crash happens with OMERO.insight-5.0.2-651-9bea7f0-ice34-b48-mac on octopus.

comment:4 Changed 7 years ago by jburel

  • Milestone changed from Unscheduled to 5.0.3

The fact that you could access big images has been fixed see https://github.com/openmicroscopy/openmicroscopy/pull/2726

comment:5 Changed 7 years ago by jburel

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.70060 sec.)

We're Hiring!