Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #12484 (closed)

Opened 7 years ago

Closed 7 years ago

BUG: ome-tiff reader throwing exception

Reported by: bramalingam Owned by: mlinkert
Priority: minor Milestone: 5.1.0-m3
Component: Bio-Formats Version: 5.0.2
Keywords: n.a. Cc:
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

Import within OMERO : QA9412

The file seems to be a file set, and only one file has been submitted.
But omero importer gives a null pointer exception, discussed with Roger and he suggested that it should still give the same error as ImageJ, where we see the error : Unmatched UUID
exception.

java.lang.NullPointerException
	at loci.formats.in.OMETiffReader.close(OMETiffReader.java:339)
	at loci.formats.ImageReader.close(ImageReader.java:536)
	at loci.formats.ReaderWrapper.close(ReaderWrapper.java:339)
	at loci.formats.ReaderWrapper.close(ReaderWrapper.java:339)
	at loci.formats.ChannelSeparator.close(ChannelSeparator.java:241)
	at loci.formats.ReaderWrapper.close(ReaderWrapper.java:339)
	at loci.formats.Memoizer.close(Memoizer.java:492)
	at loci.formats.MinMaxCalculator.close(MinMaxCalculator.java:277)
	at ome.formats.importer.OMEROWrapper.close(OMEROWrapper.java:269)
	at ome.formats.importer.ImportCandidates.singleFile(ImportCandidates.java:440)
	at ome.formats.importer.ImportCandidates.handleFile(ImportCandidates.java:596)
	at ome.formats.importer.ImportCandidates.execute(ImportCandidates.java:371)
	at ome.formats.importer.ImportCandidates.<init>(ImportCandidates.java:229)
	at ome.formats.importer.ImportCandidates.<init>(ImportCandidates.java:180)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.getImportCandidates(OMEROGateway.java:6706)
	at org.openmicroscopy.shoola.env.data.OmeroImageServiceImpl.importFile(OmeroImageServiceImpl.java:1140)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.importFile(ImagesImporter.java:77)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.access$000(ImagesImporter.java:53)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter$1.doCall(ImagesImporter.java:102)
	at org.openmicroscopy.shoola.env.data.views.BatchCall.doStep(BatchCall.java:144)
	at org.openmicroscopy.shoola.util.concur.tasks.CompositeTask.doStep(CompositeTask.java:226)
	at org.openmicroscopy.shoola.env.data.views.CompositeBatchCall.doStep(CompositeBatchCall.java:126)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.exec(ExecCommand.java:165)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.run(ExecCommand.java:276)
	at org.openmicroscopy.shoola.util.concur.tasks.AsyncProcessor$Runner.run(AsyncProcessor.java:91)
	at java.lang.Thread.run(Thread.java:695)

	at org.openmicroscopy.shoola.env.data.util.StatusLabel.update(StatusLabel.java:667)
	at ome.formats.importer.ImportCandidates.safeUpdate(ImportCandidates.java:556)
	at ome.formats.importer.ImportCandidates.singleFile(ImportCandidates.java:464)
	at ome.formats.importer.ImportCandidates.handleFile(ImportCandidates.java:596)
	at ome.formats.importer.ImportCandidates.execute(ImportCandidates.java:371)
	at ome.formats.importer.ImportCandidates.<init>(ImportCandidates.java:229)
	at ome.formats.importer.ImportCandidates.<init>(ImportCandidates.java:180)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.getImportCandidates(OMEROGateway.java:6706)
	at org.openmicroscopy.shoola.env.data.OmeroImageServiceImpl.importFile(OmeroImageServiceImpl.java:1140)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.importFile(ImagesImporter.java:77)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.access$000(ImagesImporter.java:53)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter$1.doCall(ImagesImporter.java:102)
	at org.openmicroscopy.shoola.env.data.views.BatchCall.doStep(BatchCall.java:144)
	at org.openmicroscopy.shoola.util.concur.tasks.CompositeTask.doStep(CompositeTask.java:226)
	at org.openmicroscopy.shoola.env.data.views.CompositeBatchCall.doStep(CompositeBatchCall.java:126)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.exec(ExecCommand.java:165)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.run(ExecCommand.java:276)
	at org.openmicroscopy.shoola.util.concur.tasks.AsyncProcessor$Runner.run(AsyncProcessor.java:91)
	at java.lang.Thread.run(Thread.java:695)
Caused by: java.lang.NullPointerException
	at loci.formats.in.OMETiffReader.close(OMETiffReader.java:339)
	at loci.formats.ImageReader.close(ImageReader.java:536)
	at loci.formats.ReaderWrapper.close(ReaderWrapper.java:339)
	at loci.formats.ReaderWrapper.close(ReaderWrapper.java:339)
	at loci.formats.ChannelSeparator.close(ChannelSeparator.java:241)
	at loci.formats.ReaderWrapper.close(ReaderWrapper.java:339)
	at loci.formats.Memoizer.close(Memoizer.java:492)
	at loci.formats.MinMaxCalculator.close(MinMaxCalculator.java:277)
	at ome.formats.importer.OMEROWrapper.close(OMEROWrapper.java:269)
	at ome.formats.importer.ImportCandidates.singleFile(ImportCandidates.java:440)
	... 16 more

Import within ImageJ

loci.formats.FormatException: Unmatched UUID: urn:uuid:28c3ca1b-b7e5-428e-ae81-3e84aa56f043
	at loci.formats.in.OMETiffReader.initFile(OMETiffReader.java:540)
	at loci.formats.FormatReader.setId(FormatReader.java:1317)
	at loci.plugins.in.ImportProcess.initializeFile(ImportProcess.java:494)
	at loci.plugins.in.ImportProcess.execute(ImportProcess.java:144)
	at loci.plugins.in.Importer.showDialogs(Importer.java:141)
	at loci.plugins.in.Importer.run(Importer.java:79)
	at loci.plugins.LociImporter.run(LociImporter.java:81)
	at ij.IJ.runUserPlugIn(IJ.java:201)
	at ij.IJ.runPlugIn(IJ.java:165)
	at ij.Executer.runCommand(Executer.java:131)
	at ij.Executer.run(Executer.java:64)
	at java.lang.Thread.run(Thread.java:695)

Change History (2)

comment:1 Changed 7 years ago by mlinkert

  • Milestone changed from Unscheduled to 5.0.4

comment:2 Changed 7 years ago by mlinkert

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce either error using QA 9412 and current develop. Feel free to re-open if you find that this is still reproducible.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.129770 sec.)

We're Hiring!