Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #12528 (closed)

Opened 8 years ago

Closed 7 years ago

Bug: bfconvert fails to write valid TIFF header for some planes

Reported by: rleigh Owned by: mlinkert
Priority: major Milestone: 5.1.0
Component: Bio-Formats Version: 5.0.3
Keywords: n.a. Cc: l.maier@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

See: QA 9412

Run:

% bfconvert -channel 0 in.czi o_%z.tif


% ls -ltr o_*
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_0.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_1.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_2.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_3.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_4.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_5.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_6.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_7.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_8.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_9.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_10.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_11.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_12.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_13.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_14.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_15.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_16.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_17.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_18.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_19.tif
-rw-rw-r-- 1 rleigh rleigh 427258 Aug 19 10:43 o_20.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_21.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_22.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_23.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_24.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_25.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_26.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_27.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_28.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_29.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_30.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_31.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_32.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_33.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_34.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_35.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_36.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_37.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_38.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_39.tif
-rw-rw-r-- 1 rleigh rleigh 427250 Aug 19 10:43 o_40.tif

% ls -1tr o_* | xargs file
o_0.tif:  TIFF image data, little-endian
o_1.tif:  TIFF image data, little-endian
o_2.tif:  TIFF image data, little-endian
o_3.tif:  TIFF image data, little-endian
o_4.tif:  TIFF image data, little-endian
o_5.tif:  TIFF image data, little-endian
o_6.tif:  TIFF image data, little-endian
o_7.tif:  TIFF image data, little-endian
o_8.tif:  TIFF image data, little-endian
o_9.tif:  TIFF image data, little-endian
o_10.tif: TIFF image data, little-endian
o_11.tif: TIFF image data, little-endian
o_12.tif: TIFF image data, little-endian
o_13.tif: TIFF image data, little-endian
o_14.tif: TIFF image data, little-endian
o_15.tif: TIFF image data, little-endian
o_16.tif: TIFF image data, little-endian
o_17.tif: TIFF image data, little-endian
o_18.tif: TIFF image data, little-endian
o_19.tif: TIFF image data, little-endian
o_20.tif: TIFF image data, little-endian
o_21.tif: data
o_22.tif: data
o_23.tif: data
o_24.tif: data
o_25.tif: data
o_26.tif: data
o_27.tif: data
o_28.tif: data
o_29.tif: data
o_30.tif: data
o_31.tif: data
o_32.tif: data
o_33.tif: data
o_34.tif: data
o_35.tif: data
o_36.tif: data
o_37.tif: data
o_38.tif: data
o_39.tif: data
o_40.tif: data

Looking at the data in the above files, the last 20 are missing the initial 8 byte TIFF header; all bytes after that look OK. I'm unsure what's making bfconvert miss the header just for these planes, but that looks like the root cause of the problem here.

Change History (1)

comment:1 Changed 7 years ago by mlinkert

  • Milestone changed from Unscheduled to 5.1.0
  • Resolution set to fixed
  • Status changed from new to closed

NB: the correct QA is 9452, not 9412.

I could duplicate this on develop alone, but rebuilding with https://github.com/openmicroscopy/bioformats/pull/1555 merged in solved the problem.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.90238 sec.)

We're Hiring!