Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #12548 (closed)

Opened 8 years ago

Closed 8 years ago

BUG: ND2 reader issue

Reported by: bramalingam Owned by: mlinkert
Priority: major Milestone: 5.1.0
Component: Bio-Formats Version: 5.0.3
Keywords: n.a. Cc: aryeh@…, wel@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: n.a.

Description (last modified by wmoore)

Original E-mail:

Bio-formatds no longer properly reads nd2 multifield files. I just noticed it today.

I will try to upload an example. Bsically, ir gets the frames, z-size, etc wrong.
I tried both the version distributed with Fiji, and the cersion I get when I select the bio-formats update site.
I hae not founda way to fall bakc to previous versions of bio-formats to see where things changed, I am abroad so Ido not have access to backups.
I will try to upload an image.

ok -- I verified the following:

  1. A fresh download of the newest Fiji reproduces the problem
  2. The June 2014 lifeline version works
  3. pasting the Jars/Bio?=formats directory from lifeline to latest fixes the problem.

I uploaded an nd2 multifield image set called control003.nd2. using the Fiji Help>Upload a Sample Image utility. It should be about 2 GB in size.

http://lists.openmicroscopy.org.uk/pipermail/ome-users/2014-September/004680.html QA9507
The issue was reproducible.

There is a mismatch in the metadata, between NIS elements and Bio-formats.

Change History (12)

comment:1 Changed 8 years ago by mlinkert

  • Milestone changed from Unscheduled to 5.1.0
  • Priority changed from minor to major

comment:2 Changed 8 years ago by crueden-x

See also https://github.com/imagej/imagej/issues/99, which might be related.

comment:3 Changed 8 years ago by rleigh

Also see:

https://www.openmicroscopy.org/qa2/qa2/qa/feedback/10100/
https://www.openmicroscopy.org/community/viewtopic.php?f=13&t=7651

Confirmed with current develop--dimensionality is wrong as described in the forum post above.

comment:4 Changed 8 years ago by rleigh

  • Cc wel@… added

comment:5 Changed 8 years ago by wmoore

  • Description modified (diff)

comment:7 Changed 8 years ago by mlinkert

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 8 years ago by Melissa Linkert <melissa@…>

  • Remaining Time set to 0

(In [6e6387f8206889b416fe4df9f61d72f782ca0e9e/bioformats.git] on branch develop) ND2: minor adjustments to plane size and count calculations

Fixes #12548.

comment:9 Changed 8 years ago by Melissa Linkert <melissa@…>

(In [504dfc3f1e600a5b4dd1a832eb93ae0a357b79a4/bioformats.git] on branch develop) ND2: one more set of corrections for dimension calculation

See #12548.

comment:10 Changed 8 years ago by crueden-x

  • Resolution fixed deleted
  • Status changed from closed to reopened

Aryeh Weiss wrote to the ImageJ mailing list with the following comments:

I have been unable to comment in the OME bug tracking system, but as it is relevant to Fiji, I am posting it here.

The latest update of Bio-formats still does not read my multifield ND2 files correctly. The problem still appears to be in formats-gpl.jar. Replacing that with the 5.0.2 version still works.

I checking both the bioformats distributed by the bioformats update site, and the bioformats distributed by the fiji update site.

I also downloaded the appropriate jar files from ci.openmicroscopy.org/view/Bio-Formats/job/BIOFORMATS-5.1-latest/lastSuccessfulBuild/artifact/artifacts/ and tried those. The same problem occurs, except that formats-gpl-5.0.2.jar does not work with the version 5.1 files. Falling back to 5.0.6 _ the 5.0.2 formats-gpl still works.

On the OME tracking system, this bug is said to be resolved. If so, then the corrected bioformats is not yet distributed on the fiji update sites.

So it seems that 6e6387f8 and 504dfc3f may not be a full resolution to the issue.

Dave Knecht added:

I suggested a “split positions” checkbox a while back, but that seems to not have been implemented. If there is no Z, the system interprets positions as z slices. At this point, I don’t know a way to open multichannel, multi-z, multi position datasets other than to split them in Elements.

And Aryeh further clarified:

I uploaded an rather large file when I first reported this. Since the files are quite large (2-4GB), please let me know if you still have that one before I upload another one. I cannot do an upload of that size from home.

comment:11 Changed 8 years ago by mlinkert

The problem in Bio-Formats really was resolved in https://github.com/openmicroscopy/bioformats/pull/1529.

I strongly suspect that the issue being reported now has to do with switching from 5.0.x jars to unreleased 5.1.x jars from https://ci.openmicroscopy.org/view/Bio-Formats/job/BIOFORMATS-5.1-latest/lastSuccessfulBuild/artifact/artifacts/. Making this switch requires some care, as all of the following must happen:

  1. Fiji must first be fully updated
  2. Close Fiji
  3. Open the Fiji installation folder (typically named 'Fiji.app')
  4. Remove bio-formats_plugins-5.0.7.jar from the 'plugins' sub-folder
  5. Remove all of the following from the 'jars/bio-formats' sub-folder:
    • jai_imageio-5.0.7.jar
    • formats-gpl-5.0.7.jar
    • formats-common-5.0.7.jar
    • turbojpeg-5.0.7.jar
    • ome-xml-5.0.7.jar
    • formats-bsd-5.0.7.jar
    • ome-poi-5.0.7.j.ar
    • specification-5.0.7.jar
    • mdbtools-java-5.0.7.jar
    • metakit-5.0.7.jar
    • formats-api-5.0.7.jar
  6. Download https://ci.openmicroscopy.org/view/Bio-Formats/job/BIOFORMATS-5.1-latest/lastSuccessfulBuild/artifact/artifacts/bio-formats_plugins.jar and place it in the 'plugins' sub-folder
  7. Download each of the following and place them in the 'jars/bio-formats' sub-folder:
  8. Start Fiji and open the file using "Plugins > Bio-Formats > Bio-Formats Importer"

It is vital to perform all of those steps in order; omitting even one will cause a problem. In particular, make sure that the old files are fully removed; it is not sufficient to add the new files to any sub-directory without removing the old files first.

I can confirm that performing step 1 alone results in the incorrect dimensions originally performed. Performing all 8 steps in order results in 10 stage positions, 17 Z sections, and 3 channels (for the control003.nd2 file in QA 9507) all of which match what I see in Nikon's NIS Elements Viewer.

Please do keep in mind that the jar files linked above have not been released, and should be considered alpha quality. Performing these steps may cause problems with other plugins in your Fiji installation, particularly if they make use of Bio-Formats. If you intend to open files using "File > Open", it is important to uncheck the "Use SCIFIO when opening files" option in the "Edit > Options > ImageJ2..." window.

comment:12 Changed 8 years ago by mlinkert

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.97599 sec.)

We're Hiring!