Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

User Story #1260 (closed)

Opened 11 years ago

Closed 8 years ago

Upgrade libraries (esp. Hibernate search)

Reported by: jamoore Owned by: jamoore
Priority: critical Milestone: OMERO-4.4
Component: General Keywords: n.a.
Cc: cxallan, jburel Story Points: n.a.
Sprint: n.a. Importance: n.a.
Total Remaining Time: 0.0d Estimated Remaining Time: n.a.

Description (last modified by jmoore)

This is a long-standing "upgrade" story which will hopefully be closed for 4.4.0. Follow-on stories and tasks include:

  • #7296 (story) - drop Ice 3.3 support
  • #2007 (task) - remove communicator leak workaround
  • Also see the blocked milestones.

Change History (18)

comment:1 Changed 11 years ago by jmoore

  • Cc cxallan added
  • Milestone changed from OMERO-Beta4.1 to OMERO-Beta4.2

Hibernate and lucene have moved quite a ways. Should really consider upgrading in 4.2

comment:2 Changed 11 years ago by jmoore

  • Description modified (diff)

comment:3 Changed 11 years ago by jmoore

  • Description modified (diff)

comment:4 Changed 11 years ago by jmoore

  • Description modified (diff)

comment:5 Changed 11 years ago by jmoore

  • Description modified (diff)

comment:6 Changed 10 years ago by jmoore

  • Description modified (diff)

comment:7 Changed 10 years ago by jmoore

  • Description modified (diff)

Moving tasks out to separate tickets.

comment:8 Changed 10 years ago by jmoore

  • Description modified (diff)

comment:9 Changed 10 years ago by jmoore

(In [7318]) Updating ez_setup.py for OmeroPy. See #1260

comment:10 Changed 10 years ago by jmoore

(In [7396]) Adding 0.6c11 setuptools eggs to fix #2531 (See #1174, #1260)

comment:11 Changed 9 years ago by jmoore

  • Milestone changed from Unscheduled to OMERO-Beta4.4

Moving to 4.4.0 M1 for cleanup at the end of 2011.

comment:12 Changed 9 years ago by jburel

  • Cc jburel added

comment:13 Changed 9 years ago by agilo

  • Status changed from new to accepted

Updated status, related task in progress

comment:14 Changed 9 years ago by jmoore

  • Description modified (diff)

comment:15 Changed 9 years ago by jmoore <josh@…>

(In [522318c17691bd86b2d389ca716858786d56d004/ome.git]) Add Ice 3.4 artifacts (See #1260)

Leaving the 3.3.1 artifacts in place (i.e. updating
ice-includes-3.3.0) in order to try supporting both
3.4 and 3.3.

comment:16 Changed 9 years ago by jmoore <josh@…>

(In [9335ed7c37ee066445309cde1654b2e1f1d246e4/ome.git]) Move sharing/data classes to jar (See #1260)

Since we intend to support Ice 3.3 and 3.4, it will be
necessary to have these classes in multiple versions.
These will be created via the python script under
server/src/ome/services/sharing and then stored in
lib/repository.

comment:17 Changed 9 years ago by jmoore <josh@…>

(In [cfc68df425fb977b416794993d11a3482d948bb6/ome.git]) Ice changes necessary for Ice 3.4 (See #1260)

comment:18 Changed 8 years ago by jmoore

  • Resolution set to fixed
  • Status changed from accepted to closed

Tickets which have been unlinked from this story:

  • #2258 - hibernate read-only
  • #2139 - sprint smart listeners
  • #5768 - subclasses not loaded
  • #2142 - compile warnings for spring and hibernate
  • #7218 - jhotdraw
  • #2570 - upgrade hibernate

Closed as invalid:

  • #2106 - test hibernate perf.
  • #2257 - hibernate search

Closing this story.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.270232 sec.)

We're Hiring!