Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

User Story #1260 (new)

Opened 13 years ago

Last modified 10 years ago

Upgrade libraries (esp. Hibernate search) — at Version 5

Reported by: jamoore Owned by: jamoore
Priority: critical Milestone: OMERO-Beta4.2
Component: General Keywords: n.a.
Cc: cxallan, jburel Story Points: n.a.
Sprint: n.a. Importance: n.a.
Total Remaining Time: 0.0d Estimated Remaining Time: n.a.

Description (last modified by jmoore)

Includes:

  • Latest Hibernate & especially search for performance reasons
  • Ice 3.4.x if available (#1274)
  • Spring 3.0
  • see #1642 (IPython in own dir)
  • testng : see #561

Afterwards, review blocked milestone.

Change History (5)

comment:1 Changed 13 years ago by jmoore

  • Cc cxallan added
  • Milestone changed from OMERO-Beta4.1 to OMERO-Beta4.2

Hibernate and lucene have moved quite a ways. Should really consider upgrading in 4.2

comment:2 Changed 13 years ago by jmoore

  • Description modified (diff)

comment:3 Changed 13 years ago by jmoore

  • Description modified (diff)

comment:4 Changed 13 years ago by jmoore

  • Description modified (diff)

comment:5 Changed 13 years ago by jmoore

  • Description modified (diff)
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.97879 sec.)

We're Hiring!