Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #12722 (closed)

Opened 7 years ago

Closed 7 years ago

RFE: graphs error reporting in Insight

Reported by: mtbcarroll Owned by: dlindner
Priority: minor Milestone: 5.1.0
Component: Insight Version: n.a.
Keywords: n.a. Cc: ux@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

A failure to move or delete images in Insight does not make the actual error returned from the server obvious to the user. A general ERR response will include a stack trace; a GraphException will even include a useful human-readable message: see https://github.com/mtbc/openmicroscopy/commit/24039f25. It would be great if Insight could make the error easier for the user to perceive, thus get fixed.

A move failure can be caused by projecting an image and trying to move only its projection; a delete failure can be caused by deleting a tag with which another user tagged their own image. (Or, myriad other ways!)

Change History (1)

comment:1 Changed 7 years ago by dlindner

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.63275 sec.)

We're Hiring!