Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #12741 (closed)

Opened 5 years ago

Closed 5 years ago

BUG:LIFReader, IllegalArgumentException

Reported by: omero-qa Owned by: jburel
Priority: minor Milestone: 5.1.1
Component: Bio-Formats Version: 5.0.8
Keywords: n.a. Cc: holger.vogel@…, mlinkert
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

https://www.openmicroscopy.org/qa2/qa2/qa/feedback/10480/

java.lang.IllegalArgumentException: 0 must not be null and positive.
	at ome.xml.model.primitives.PositiveInteger.<init>(PositiveInteger.java:48)
	at loci.formats.MetadataTools.populatePixelsOnly(MetadataTools.java:271)
	at loci.formats.MetadataTools.populateMetadata(MetadataTools.java:234)
	at loci.formats.MetadataTools.populatePixels(MetadataTools.java:134)
	at loci.formats.in.LIFReader.initMetadata(LIFReader.java:566)
	at loci.formats.in.LIFReader.initFile(LIFReader.java:459)
	at loci.formats.FormatReader.setId(FormatReader.java:1395)
	at loci.formats.ImageReader.setId(ImageReader.java:835)
	at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:651)
	at loci.formats.ChannelFiller.setId(ChannelFiller.java:223)
	at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:651)
	at loci.formats.ChannelSeparator.setId(ChannelSeparator.java:289)
	at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:651)
	at loci.formats.Memoizer.setId(Memoizer.java:614)
	at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:651)
	at ome.formats.importer.ImportCandidates.singleFile(ImportCandidates.java:414)
	at ome.formats.importer.ImportCandidates.handleFile(ImportCandidates.java:596)
	at ome.formats.importer.ImportCandidates.execute(ImportCandidates.java:371)
	at ome.formats.importer.ImportCandidates.<init>(ImportCandidates.java:229)
	at ome.formats.importer.ImportCandidates.<init>(ImportCandidates.java:180)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.getImportCandidates(OMEROGateway.java:6738)
	at org.openmicroscopy.shoola.env.data.OmeroImageServiceImpl.importFile(OmeroImageServiceImpl.java:1186)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.importFile(ImagesImporter.java:80)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.access$000(ImagesImporter.java:55)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter$1.doCall(ImagesImporter.java:104)
	at org.openmicroscopy.shoola.env.data.views.BatchCall.doStep(BatchCall.java:144)
	at org.openmicroscopy.shoola.util.concur.tasks.CompositeTask.doStep(CompositeTask.java:226)
	at org.openmicroscopy.shoola.env.data.views.CompositeBatchCall.doStep(CompositeBatchCall.java:126)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.exec(ExecCommand.java:165)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.run(ExecCommand.java:276)
	at org.openmicroscopy.shoola.util.concur.tasks.AsyncProcessor$Runner.run(AsyncProcessor.java:91)
	at java.lang.Thread.run(Thread.java:745)

	at org.openmicroscopy.shoola.env.data.util.StatusLabel.update(StatusLabel.java:668)
	at ome.formats.importer.ImportCandidates.safeUpdate(ImportCandidates.java:556)
	at ome.formats.importer.ImportCandidates.singleFile(ImportCandidates.java:464)
	at ome.formats.importer.ImportCandidates.handleFile(ImportCandidates.java:596)
	at ome.formats.importer.ImportCandidates.execute(ImportCandidates.java:371)
	at ome.formats.importer.ImportCandidates.<init>(ImportCandidates.java:229)
	at ome.formats.importer.ImportCandidates.<init>(ImportCandidates.java:180)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.getImportCandidates(OMEROGateway.java:6738)
	at org.openmicroscopy.shoola.env.data.OmeroImageServiceImpl.importFile(OmeroImageServiceImpl.java:1186)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.importFile(ImagesImporter.java:80)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.access$000(ImagesImporter.java:55)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter$1.doCall(ImagesImporter.java:104)
	at org.openmicroscopy.shoola.env.data.views.BatchCall.doStep(BatchCall.java:144)
	at org.openmicroscopy.shoola.util.concur.tasks.CompositeTask.doStep(CompositeTask.java:226)
	at org.openmicroscopy.shoola.env.data.views.CompositeBatchCall.doStep(CompositeBatchCall.java:126)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.exec(ExecCommand.java:165)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.run(ExecCommand.java:276)
	at org.openmicroscopy.shoola.util.concur.tasks.AsyncProcessor$Runner.run(AsyncProcessor.java:91)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.IllegalArgumentException: 0 must not be null and positive.
	at ome.xml.model.primitives.PositiveInteger.<init>(PositiveInteger.java:48)
	at loci.formats.MetadataTools.populatePixelsOnly(MetadataTools.java:271)
	at loci.formats.MetadataTools.populateMetadata(MetadataTools.java:234)
	at loci.formats.MetadataTools.populatePixels(MetadataTools.java:134)
	at loci.formats.in.LIFReader.initMetadata(LIFReader.java:566)
	at loci.formats.in.LIFReader.initFile(LIFReader.java:459)
	at loci.formats.FormatReader.setId(FormatReader.java:1395)
	at loci.formats.ImageReader.setId(ImageReader.java:835)
	at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:651)
	at loci.formats.ChannelFiller.setId(ChannelFiller.java:223)
	at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:651)
	at loci.formats.ChannelSeparator.setId(ChannelSeparator.java:289)
	at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:651)
	at loci.formats.Memoizer.setId(Memoizer.java:614)
	at loci.formats.ReaderWrapper.setId(ReaderWrapper.java:651)
	at ome.formats.importer.ImportCandidates.singleFile(ImportCandidates.java:414)
	... 16 more

Change History (8)

comment:1 Changed 5 years ago by mlinkert

  • Component changed from from QA to Bio-Formats
  • Milestone changed from Unscheduled to 5.1.1
  • Owner changed from mlinkert-x to mlinkert

comment:2 Changed 5 years ago by jburel

The file is composed of 9 images. 6 of them have a sizeX = 0 leading to the error
The other sizes (y,c,z,t) are > 0.
Do we exclude those images in that case? i.e. keep the 3 "valid" ones

Last edited 5 years ago by jburel (previous) (diff)

comment:3 Changed 5 years ago by mlinkert

Does LAS AF Lite (the free viewer from Leica) also show sizeX == 0 for those 6 images? If so, it's probably fine to ignore them and keep the remaining 3; otherwise, the sizeX setting will need to be fixed.

comment:4 Changed 5 years ago by jburel

I have not tried it yet.

comment:5 Changed 5 years ago by jburel

  • Owner changed from mlinkert to jburel

comment:6 Changed 5 years ago by jburel

  • Cc mlinkert added

comment:7 Changed 5 years ago by jburel

6 out of the 9 are listed under LAS AF lite as ClimateDataGraph(Value, t) Value being 22, 72 etc

Last edited 5 years ago by jburel (previous) (diff)

comment:8 Changed 5 years ago by jburel

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.212766 sec.)

We're Hiring!