Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #13055 (closed)

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

BUG: 'Open with' fails

Reported by: dlindner Owned by: dlindner
Priority: major Milestone: OMERO-5.2.1
Component: Insight Version: n.a.
Keywords: n.a. Cc: m.porter@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

'Open with' action fails. Shows an error message that a weird formatted path could not be found.

Initially I thought it might be a path formatting problem on Windows, but the action worked for me (so the path apparently is just messed up in the error dialog). Must be related to the file, asked Michael to provide an example file.

Change History (9)

comment:1 Changed 8 years ago by dlindner

  • Milestone changed from Unscheduled to 5.2.0
  • Version OMERO-5.2.0-m0 deleted

comment:2 Changed 8 years ago by dlindner

  • Milestone changed from 5.2.0 to OMERO-5.2.0

comment:3 Changed 8 years ago by jburel

Did you get the file?

comment:4 Changed 8 years ago by dlindner

  • Cc m.porter@… added

Just got an email from Michael. Seems to be a Fiji/ImageJ problem. I was quite sure, we tried to open with the default image preview on Windows as well, and it also failed, so I assumed it's an image export problem. Have to check that again.

comment:5 Changed 8 years ago by dlindner

Ok, just confirmed, this is a Fiji/ImageJ problem. Insight successfully exports the image to a tif file, which can be opened without problems with other programs, but Fiji/ImageJ fails (apparently doesn't forward the path to the image correctly to the bioformats importer).

comment:6 Changed 8 years ago by dlindner

  • Component changed from Insight to General
  • Milestone changed from OMERO-5.2.0 to OMERO-5.2.1

Pushing to 5.2.1. Will investigate this again, and maybe file a ticket for Fiji/ImageJ.

comment:7 Changed 8 years ago by dlindner

  • Component changed from General to Insight
  • Resolution set to fixed
  • Status changed from new to closed

Turned out to be an Insight issue:
Fixed by: https://github.com/openmicroscopy/openmicroscopy/pull/4299

comment:8 Changed 8 years ago by jburel

  • Milestone changed from OMERO-5.2.1 to OMERO-5.2.2

Milestone OMERO-5.2.1 deleted

comment:9 Changed 8 years ago by jburel

  • Milestone changed from OMERO-5.2.2 to OMERO-5.2.1

Milestone OMERO-5.2.2 deleted

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.65378 sec.)

We're Hiring!