Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #13078 (closed)

Opened 6 years ago

Closed 6 years ago

BUG: ClassCastException RawPixelsStore

Reported by: mporter Owned by: dlindner
Priority: blocker Milestone: OMERO-5.2.0
Component: Services Version: OMERO-5.1.3
Keywords: n.a. Cc:
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

Apparently happens since 5.1.4 and only on OSX, using mtools.

Error using getRawPixelsStore (line 54)
Java exception occurred: 
java.lang.ClassCastException: java.lang.Character cannot be cast to java.lang.String
	at Ice.ContextHelper.write(ContextHelper.java:38)
	at IceInternal.Outgoing.writeHeader(Outgoing.java:609)
	at IceInternal.Outgoing.<init>(Outgoing.java:31)
	at IceInternal.ConnectRequestHandler.getOutgoing(ConnectRequestHandler.java:195)
	at omero.api._RawPixelsStoreDelM.setPixelsId(_RawPixelsStoreDelM.java:1595)
	at omero.api.RawPixelsStorePrxHelper.setPixelsId(RawPixelsStorePrxHelper.java:7843)
	at omero.api.RawPixelsStorePrxHelper.setPixelsId(RawPixelsStorePrxHelper.java:7821)

Error in getPlane (line 44)



Error in boxIt>getImagePlane (line 178)



Error in boxIt>zSlider_Callback (line 266)



Error in gui_mainfcn (line 96)



Error in boxIt (line 43)



Error in @(hObject,eventdata)boxIt('zSlider_Callback',hObject,eventdata,guidata(hObject))


Attachments (1)

mtoolsLog.log (3.5 KB) - added by dlindner 6 years ago.
Complete log

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by dlindner

Complete log

comment:1 Changed 6 years ago by dlindner

  • Owner set to dlindner

comment:2 Changed 6 years ago by jburel

  • Milestone changed from Unscheduled to OMERO-5.2.0
  • Priority changed from minor to blocker

increasing the priority
mtools is not usable
similar issue fixed see https://github.com/openmicroscopy/openmicroscopy/pull/4286

comment:3 Changed 6 years ago by dlindner

  • Resolution set to fixed
  • Status changed from new to closed

Has been fixed by Sebastien in above mentioned PR, tested by Michael with 5.2.0-rc1 build.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.79383 sec.)

We're Hiring!