Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #13157 (closed)

Opened 7 years ago

Closed 6 years ago

BUG: ROI tool, pixel sizes

Reported by: dlindner Owned by: bramalingam
Priority: minor Milestone: ROI
Component: Insight Version: OMERO-5.2.0
Keywords: n.a. Cc:
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

See https://www.openmicroscopy.org/qa2/qa/feedback/17027/ and https://www.openmicroscopy.org/qa2/qa/feedback/17030

Unfortunately I couldn't replicate this, yet.

java.lang.Exception: Abnormal termination due to an uncaught exception.
java.lang.IllegalArgumentException: Can't use different units for the pixel sizes.
	at org.openmicroscopy.shoola.util.roi.model.util.MeasurementUnits.setPixelSizes(MeasurementUnits.java:98)
	at org.openmicroscopy.shoola.util.roi.ROIComponent.setPixelSizes(ROIComponent.java:208)
	at org.openmicroscopy.shoola.agents.measurement.view.MeasurementViewerModel.(MeasurementViewerModel.java:273)
	at org.openmicroscopy.shoola.agents.measurement.view.MeasurementViewerFactory.getViewer(MeasurementViewerFactory.java:122)
	at org.openmicroscopy.shoola.agents.measurement.MeasurementAgent.handleMeasurementToolEvent(MeasurementAgent.java:89)
	at org.openmicroscopy.shoola.agents.measurement.MeasurementAgent.eventFired(MeasurementAgent.java:375)
	at org.openmicroscopy.shoola.env.event.EventBusImpl.dispatch(EventBusImpl.java:91)
	at org.openmicroscopy.shoola.env.event.EventBusImpl.post(EventBusImpl.java:222)
	at org.openmicroscopy.shoola.agents.imviewer.view.ImViewerComponent.postMeasurementEvent(ImViewerComponent.java:501)
	at org.openmicroscopy.shoola.agents.imviewer.view.ImViewerComponent.showMeasurementTool(ImViewerComponent.java:2016)
	at org.openmicroscopy.shoola.agents.imviewer.actions.ROIToolAction.mouseReleased(ROIToolAction.java:145)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:290)
	at java.awt.Component.processMouseEvent(Component.java:6505)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3321)
	at java.awt.Component.processEvent(Component.java:6270)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:723)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:682)
	at java.awt.EventQueue$3.run(EventQueue.java:680)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:696)
	at java.awt.EventQueue$4.run(EventQueue.java:694)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:693)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Abnormal termination due to an uncaught exception.
java.lang.IllegalArgumentException: Can't use different units for the pixel sizes.
	at org.openmicroscopy.shoola.util.roi.model.util.MeasurementUnits.setPixelSizes(MeasurementUnits.java:98)
	at org.openmicroscopy.shoola.util.roi.ROIComponent.setPixelSizes(ROIComponent.java:208)
	at org.openmicroscopy.shoola.agents.measurement.view.MeasurementViewerModel.(MeasurementViewerModel.java:273)
	at org.openmicroscopy.shoola.agents.measurement.view.MeasurementViewerFactory.getViewer(MeasurementViewerFactory.java:122)
	at org.openmicroscopy.shoola.agents.measurement.MeasurementAgent.handleMeasurementToolEvent(MeasurementAgent.java:89)
	at org.openmicroscopy.shoola.agents.measurement.MeasurementAgent.eventFired(MeasurementAgent.java:375)
	at org.openmicroscopy.shoola.env.event.EventBusImpl.dispatch(EventBusImpl.java:91)
	at org.openmicroscopy.shoola.env.event.EventBusImpl.post(EventBusImpl.java:222)
	at org.openmicroscopy.shoola.agents.imviewer.view.ImViewerComponent.postMeasurementEvent(ImViewerComponent.java:501)
	at org.openmicroscopy.shoola.agents.imviewer.view.ImViewerComponent.showMeasurementTool(ImViewerComponent.java:2016)
	at org.openmicroscopy.shoola.agents.imviewer.actions.ROIToolAction.mouseReleased(ROIToolAction.java:145)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:290)
	at java.awt.Component.processMouseEvent(Component.java:6505)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3321)
	at java.awt.Component.processEvent(Component.java:6270)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:723)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:682)
	at java.awt.EventQueue$3.run(EventQueue.java:680)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:696)
	at java.awt.EventQueue$4.run(EventQueue.java:694)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:693)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Exception in thread "AWT-EventQueue-0"


	at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.showErrorDialog(UserNotifierImpl.java:189)
	at org.openmicroscopy.shoola.env.ui.UserNotifierImpl.notifyError(UserNotifierImpl.java:289)
	at org.openmicroscopy.shoola.env.AbnormalExitHandler.doTermination(AbnormalExitHandler.java:147)
	at org.openmicroscopy.shoola.env.AbnormalExitHandler.terminate(AbnormalExitHandler.java:85)
	at org.openmicroscopy.shoola.env.RootThreadGroup.uncaughtException(RootThreadGroup.java:69)
	at java.awt.EventDispatchThread.processException(EventDispatchThread.java:264)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:256)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Change History (4)

comment:1 Changed 7 years ago by jamoore

  • Milestone changed from Unscheduled to ROI

comment:2 Changed 7 years ago by dlindner

Balaji managed to reproduce it, the image comes from kymograph script:
https://www.openmicroscopy.org/qa2/qa/feedback/17256/

comment:3 Changed 6 years ago by dlindner

  • Owner changed from dlindner to bramalingam

It's a problem with the kymograph script. If no time increment is provided, it produces an image with pixel size X, but no pixel size Y.
Passing on to Balaji.

comment:4 Changed 6 years ago by bramalingam

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.101793 sec.)

We're Hiring!