Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Bug #13316 (closed)

Opened 5 years ago

Closed 5 years ago

nd2 to tiff conversion issues

Reported by: dgault Owned by:
Priority: major Cc: dgault
Sprint: n.a.
Total Remaining Time: n.a.

Description

Issue was raised by user in forum thread: https://www.openmicroscopy.org/community/viewtopic.php?f=13&t=8180
Sample file can be found in QA-17475

Using the sample file provided run the following command:
bfconvert -channel 0 field001.nd2 field001.tif

The following Exception is encountered:
Exception in thread "main" java.lang.IllegalArgumentException?: Invalid image index: 24/22

at loci.formats.FormatTools?.getZCTCoords(FormatTools?.java:641)
at loci.formats.FormatTools?.getFilename(FormatTools?.java:1124)
at loci.formats.FormatTools?.getFilename(FormatTools?.java:1101)
at loci.formats.FormatTools?.getFilename(FormatTools?.java:1088)
at testing.BF_ImageConverter.testConvert(BF_ImageConverter.java:553)
at testing.ImageConvertTest?.main(ImageConvertTest?.java:66)

Change History (2)

comment:1 Changed 5 years ago by sbesson

See also https://www.openmicroscopy.org/community/viewtopic.php?f=13&t=8182#p17798 for a more detailed description of the various scenarios.

Note I can reproduce the issue with fake files so this is completely independent of the input file

bfconvert -channel 0 "test&sizeC=2&sizeZ=2&sizeT=2.fake" out.ome.tiff

Doing some minimal bisection, it looks like this regression was introduced between 5.2.1 and 5.2.2, likely as a result of following https://github.com/openmicroscopy/bioformats/issues/2490.

comment:2 Changed 5 years ago by sbesson

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.62024 sec.)

We're Hiring!