Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #13318 (closed)

Opened 4 years ago

Closed 17 months ago

BUG: ImarisHDFReader -new version of files not being read by BF

Reported by: bramalingam Owned by:
Priority: minor Milestone: Unscheduled
Component: Bio-Formats Version: Bio-Formats-5.1.8
Keywords: n.a. Cc: Ann.Wheeler@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

ref: http://lists.openmicroscopy.org.uk/pipermail/ome-devel/2017-January/003868.html
https://www.openmicroscopy.org/qa2/qa/feedback/17515/

Testing summary:
Tested with BF 5.3.2 and the error reported was reproducible :

stacktrace:

java.io.IOException: java.lang.IllegalStateException: MessageDataspace: unknown version= 49
	at ucar.nc2.NetcdfFile.open(NetcdfFile.java:425)
	at ucar.nc2.NetcdfFile.open(NetcdfFile.java:392)
	at ucar.nc2.NetcdfFile.open(NetcdfFile.java:379)
	at ucar.nc2.NetcdfFile.open(NetcdfFile.java:367)
	at loci.formats.services.NetCDFServiceImpl.init(NetCDFServiceImpl.java:307)
	at loci.formats.services.NetCDFServiceImpl.setFile(NetCDFServiceImpl.java:100)
	at loci.formats.in.ImarisHDFReader.initFile(ImarisHDFReader.java:247)
	at loci.formats.FormatReader.setId(FormatReader.java:1399)
	at loci.plugins.in.ImportProcess.initializeFile(ImportProcess.java:498)
	at loci.plugins.in.ImportProcess.execute(ImportProcess.java:141)
	at loci.plugins.in.Importer.showDialogs(Importer.java:140)
	at loci.plugins.in.Importer.run(Importer.java:76)
	at loci.plugins.LociImporter.run(LociImporter.java:78)
	at ij.IJ.runUserPlugIn(IJ.java:217)
	at ij.IJ.runPlugIn(IJ.java:181)
	at ij.Executer.runCommand(Executer.java:137)
	at ij.Executer.run(Executer.java:66)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.IllegalStateException: MessageDataspace: unknown version= 49
	at ucar.nc2.iosp.hdf5.H5header$MessageDataspace.read(H5header.java:2826)
	at ucar.nc2.iosp.hdf5.H5header$MessageAttribute.read(H5header.java:3683)
	at ucar.nc2.iosp.hdf5.H5header$DataObject.processAttributeInfoMessage(H5header.java:2364)
	at ucar.nc2.iosp.hdf5.H5header$DataObject.<init>(H5header.java:2332)
	at ucar.nc2.iosp.hdf5.H5header$DataObject.<init>(H5header.java:2180)
	at ucar.nc2.iosp.hdf5.H5header.getDataObject(H5header.java:2027)
	at ucar.nc2.iosp.hdf5.H5header.access$600(H5header.java:70)
	at ucar.nc2.iosp.hdf5.H5header$DataObjectFacade.<init>(H5header.java:2073)
	at ucar.nc2.iosp.hdf5.H5header.readGroupNew(H5header.java:3920)
	at ucar.nc2.iosp.hdf5.H5header.access$900(H5header.java:70)
	at ucar.nc2.iosp.hdf5.H5header$H5Group.<init>(H5header.java:2153)
	at ucar.nc2.iosp.hdf5.H5header$H5Group.<init>(H5header.java:2118)
	at ucar.nc2.iosp.hdf5.H5header.makeNetcdfGroup(H5header.java:472)
	at ucar.nc2.iosp.hdf5.H5header.read(H5header.java:215)
	at ucar.nc2.iosp.hdf5.H5iosp.open(H5iosp.java:128)
	at ucar.nc2.NetcdfFile.<init>(NetcdfFile.java:1521)
	at ucar.nc2.NetcdfFile.open(NetcdfFile.java:813)
	at ucar.nc2.NetcdfFile.open(NetcdfFile.java:422)
	... 17 more

Change History (1)

comment:1 Changed 17 months ago by sbesson

  • Resolution set to fixed
  • Status changed from new to closed

Closed with https://github.com/openmicroscopy/bioformats/pull/3358. This will be included in the next Bio-Formats release

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.212878 sec.)

We're Hiring!