Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Bug #1499 (closed)

Opened 13 years ago

Closed 13 years ago

Import regressions due to refactoring for CLI

Reported by: jamoore Owned by: bwzloranger
Priority: blocker Cc: jrswedlow, jburel
Sprint: n.a.
Total Remaining Time: n.a.

Description (last modified by bwzloranger)

To have much of the newer ImportLibrary functionality in both the cli and the gui versions, refactoring was necessary which introduced several bugs:

Fixed

  • importer-win.bat fails with NPE. See description below. (fixed r5191)
  • feedback no longer uploads files (fixed)
  • warning printed: "Couldn't find icon: gfx/warning_msg16.png" (fixed)
  • re-login panel has issues (fixed)
  • properties on error dialog not saved (fixed)
  • history not showing up (fixed)
  • history not 'reimporting'(fixed)
  • files which fail during importcandidate not showing up on queue (fixed)
  • error in filequeue not being added to feedback queue (fixed)
  • eclipse builds failing without testng being built (fixed)
  • feedback no longer recording some properties (such as 'additional_files_path' and 'additional_files_size') (fixed)
  • 'internal errors' not providing required information for feedback such as reader file types (fixed)
  • Properties on error feedback not being saved (fixed)
  • Properties on project/dataset/spw not being saved (fixed)
  • On failed files, popup no longer showing up at the end of the import process. (fixed)
  • Some error messages (Internal Errors) no longer appear to be providing the full stack trace to the feedback mechanism (fixed)
  • ImportCandidate? interfering with the reader used during imports so clicking on the 'add button' will poison the import reader if its running, causing imports to fail - ImportCandidate? will probably need to be moved to its own reader. (Fixed by disabling the add button for now)
  • Added importHandler events for IMPORT_QUEUE_DONE - some code from this class can now be moved back into the classes where they belong. (fixed)
  • Added importHandler event for IMPORT_QUEUE_START (fixed)
  • Icon for debug message popup wrong (fixed)
  • Failure dialog and project/dataset dialog both modal and blocking each other. (fixed)
  • UserSpecifiedFileNames? not working (fixed)
  • progress bar can get lost behind other windows (fixed)
  • It is no longer possible to log into the server more then once from the same machine. (fixed)
  • remove logging: "2009-10-06 21:42:32,588 124833 [1-thread-1] INFO me.formats.importer.gui.FileQueueHandler? - Calling event: ome.formats.importer.util.ErrorHandler?$UNKNOWN_FORMAT" (fixed)
  • "processing directories..." when I click on a file is confusing. (fixed)
  • ImportCandidates? needs to have functionality to cancel as it currently blocks all gui function while running. (fixed)
  • Bio-formats version added to about (fixed)
  • files do not preserve the name specified for them in the import dialog (fixed)
  • mac app and windows exe fail (fixed)
  • Properties on filechooser not being saved (fixed)
  • Have a popup show up when errors added during candidate phase. (fixed)
  • Feedback dialog not showing email address (fixed)
  • Change checkbox to remove the send of feedback (fixed)
  • OME Tiffs should import as dataset images not spw (for now) (fixed)
  • If a file format is picked in the filechooser, only add those file types to the queue (fixed)
  • Importer version should be taken from omero.properties (fixed)
  • popup warning on MISSING_LIBRARY (see r5271) (fixed)
  • popup on "unknown format" (fixed)
    • cancelling a directory scan can lead to SPW/non-SPW warnings (fixed)
  • #1486 returning null from ImportCandidates.singleFile (fixed)
  • NPE from #1503 (see below) (fixed)
  • Filed added via reimport do nothing when 'import' button clicked. (fixed)
  • mouseover since multiple files can be added in one click? (moved to r1550)
  • App hangs on !OOM (moved to r1551)
  • re-use ErrorHandler? where possible (see r5271) (moved to r1552)
  • When ping session dies, app does not properly register as 'logged out'
    (moved to r1553)
  • frequent updates to Debug tab might be hanging GUI (moved to r1554)

Change History (69)

comment:1 Changed 13 years ago by jmoore

  • Description modified (diff)

comment:2 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:3 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:4 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:5 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:6 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:7 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:8 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:9 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:10 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:11 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:12 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:13 Changed 13 years ago by jmoore

  • Description modified (diff)

comment:14 Changed 13 years ago by jmoore

  • Description modified (diff)

comment:15 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:16 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:17 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:18 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:19 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:20 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:21 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:22 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:23 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:24 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:25 Changed 13 years ago by jmoore

  • Description modified (diff)

Further explanation on "mouseover since multiple files":

If a user clicks a directory, say "My Plates" for import, then a single file will show up for each plate. Something of the form: mode0001_z001_t0001.tif. The user will have no way to know which one relates to which plate.

comment:26 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:27 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:28 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:29 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:30 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:31 Changed 13 years ago by jmoore

  • Description modified (diff)

From #1503 error.log:

11	Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
12	        at javax.swing.text.DefaultStyledDocument.getCharacterElement(Unknown Source)
13	        at javax.swing.text.StyledEditorKit$AttributeTracker.updateInputAttributes(Unknown Source)
14	        at javax.swing.text.StyledEditorKit$AttributeTracker.caretUpdate(Unknown Source)
15	        at javax.swing.text.JTextComponent.fireCaretUpdate(Unknown Source)
16	        at javax.swing.text.JTextComponent$MutableCaretEvent.fire(Unknown Source)
17	        at javax.swing.text.JTextComponent$MutableCaretEvent.stateChanged(Unknown Source)
18	        at javax.swing.text.DefaultCaret.fireStateChanged(Unknown Source)
19	        at javax.swing.text.DefaultCaret.changeCaretPosition(Unknown Source)
20	        at javax.swing.text.DefaultCaret.handleSetDot(Unknown Source)
21	        at javax.swing.text.DefaultCaret.setDot(Unknown Source)
22	        at javax.swing.text.DefaultCaret.setDot(Unknown Source)
23	        at javax.swing.text.JTextComponent.setCaretPosition(Unknown Source)
24	        at ome.formats.importer.gui.GuiImporter$5.adjustmentValueChanged(GuiImporter.java:317) 

comment:32 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:33 Changed 13 years ago by jmoore

  • Description modified (diff)

Brian, I've reworked ImportConfig? to not load or save as many properties. The login issues were possibly being caused by a session key being persisted. Let's get the blocking of ImportCandidates? fixed ASAP, and then move on to testing all these different code paths. We'll probably need a list.

comment:34 Changed 13 years ago by jmoore

sorry, meant to mention: r5189

comment:35 Changed 13 years ago by jmoore

  • Description modified (diff)
  • Priority changed from critical to blocker
java.lang.NullPointerException
        at ome.formats.importer.gui.LoginHandler.displayLoginDialog(LoginHandler
.java:277)
        at ome.formats.importer.gui.LoginHandler.displayLogin(LoginHandler.java:
119)
        at ome.formats.importer.gui.LoginHandler.<init>(LoginHandler.java:111)
        at ome.formats.importer.gui.LoginHandler.<init>(LoginHandler.java:93)
        at ome.formats.importer.gui.GuiImporter.<init>(GuiImporter.java:347)
        at ome.formats.importer.gui.GuiImporter.main(GuiImporter.java:617)
        at ome.formats.importer.Main.main(Main.java:34)

comment:36 Changed 13 years ago by jmoore

  • Description modified (diff)

I think I fixed one NPE. But the hang on OutOfMemory? is very disturbing!

Exception in thread "Thread-11" java.lang.OutOfMemoryError: Java heap space
        at loci.common.RandomAccessInputStream.reopen(RandomAccessInputStream.ja
va:626)
        at loci.common.RandomAccessInputStream.<init>(RandomAccessInputStream.ja
va:124)
        at loci.formats.in.MinimalTiffReader.initFile(MinimalTiffReader.java:214
)
        at loci.formats.FormatReader.setId(FormatReader.java:366)
        at loci.formats.in.MIASReader.getTile(MIASReader.java:821)
        at loci.formats.in.MIASReader.openBytes(MIASReader.java:194)
        at loci.formats.ImageReader.openBytes(ImageReader.java:339)
        at loci.formats.ChannelFiller.openBytes(ChannelFiller.java:172)
        at loci.formats.ChannelSeparator.openBytes(ChannelSeparator.java:191)
        at loci.formats.ReaderWrapper.openBytes(ReaderWrapper.java:273)
        at loci.formats.MinMaxCalculator.openBytes(MinMaxCalculator.java:246)
        at loci.formats.MinMaxCalculator.openBytes(MinMaxCalculator.java:229)
        at ome.formats.importer.OMEROWrapper.openPlane2D(OMEROWrapper.java:109)
        at ome.formats.importer.ImportLibrary.importData(ImportLibrary.java:451)

        at ome.formats.importer.ImportLibrary.importImage(ImportLibrary.java:319
)
        at ome.formats.importer.gui.ImportHandler.importImages(ImportHandler.jav
a:184)
        at ome.formats.importer.gui.ImportHandler.access$000(ImportHandler.java:
48)
        at ome.formats.importer.gui.ImportHandler$1.run(ImportHandler.java:99)

comment:37 Changed 13 years ago by jmoore

  • Description modified (diff)

comment:38 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:39 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:40 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:41 Changed 13 years ago by jmoore

  • Description modified (diff)

comment:42 Changed 13 years ago by jmoore

  • Description modified (diff)

comment:43 Changed 13 years ago by jmoore

  • Description modified (diff)

comment:44 Changed 13 years ago by jmoore

  • Description modified (diff)

comment:45 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:46 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:47 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:48 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:49 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:50 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:51 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:52 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:53 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:54 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:55 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:56 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:57 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:58 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:59 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:60 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:61 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:62 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:63 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:64 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:65 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:66 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:67 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:68 Changed 13 years ago by bwzloranger

  • Description modified (diff)

comment:69 Changed 13 years ago by bwzloranger

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.141534 sec.)

We're Hiring!