Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #1707 (closed)

Opened 11 years ago

Closed 9 years ago

Missing slice2cpp fails the build

Reported by: jamoore Owned by: jamoore
Priority: major Milestone: OMERO-4.4
Component: Deployment Version: 4.1
Keywords: n.a. Cc: cxallan, carlos@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: 2011-11-29 (3)

Description

Problem

Due to differing packaging schemes across OSes, users may forget to install slice2cpp causing the following during build:

-sh-3.1$ ./build.py
....
icegen2:
Copying 138 files to /home/weblitz/ASCB_omero/components/blitz/generated
Copying 138 files to /home/weblitz/ASCB_omero/components/blitz/generated
Copying 138 files to /home/weblitz/ASCB_omero/components/blitz/generated
Copying 138 files to /home/weblitz/ASCB_omero/components/blitz/generated
Copying 138 files to /home/weblitz/ASCB_omero/components/blitz/generated
Copying 1 file to /home/weblitz/ASCB_omero/components/blitz/generated
Building with ICE_HOME=/usr/share/Ice
Debug setting: True (debug)
os.chdir('/home/weblitz/ASCB_omero/components/blitz/resources')
slice(["omero/API.h", "omero/API.cpp"], ["omero/API.ice"])
os.chdir('/home/weblitz/ASCB_omero/components/blitz')
scons: *** [omero/API.h] No such file or directory

BUILD FAILED
/home/weblitz/ASCB_omero/build.xml:117: The following error occurred while executing this line:
/home/weblitz/ASCB_omero/components/antlib/resources/global.xml:109: The following error occurred while executing this line:
/home/weblitz/ASCB_omero/components/blitz/build.xml:203: The following error occurred while executing this line:
/home/weblitz/ASCB_omero/components/antlib/resources/global.xml:196: exec returned: 2

Total time: 23 seconds
-sh-3.1$ slice2cpp
-sh: slice2cpp: command not found

Proper fix

blitz_tools.py possibly should detect that slice2cpp is missing, and either not try to call it, or should print out a message to the user.

Workaround A

-sh-3.1$ slice2cpp
-sh: slice2cpp: command not found
-sh-3.1$ echo 'export PATH=$PATH:$HOME/bin' > .bashrc
-sh-3.1$ source .bashrc
-sh-3.1$ mkdir $HOME/bin
-sh-3.1$ ln -s /bin/true $HOME/bin/slice2cpp

Workaround B

Install the package. On Centos:

-sh-3.1$ yum list | grep "^ice-"
ice-java.noarch                          3.3.0-1.rhel5          installed       
ice-java-devel.x86_64                    3.3.0-1.rhel5          installed       
ice-libs.x86_64                          3.3.0-1.rhel5          installed       
ice-python.x86_64                        3.3.0-1.rhel5          installed       
ice-python-devel.x86_64                  3.3.0-1.rhel5          installed       
ice-servers.x86_64                       3.3.0-1.rhel5          installed       
ice-utils.x86_64                         3.3.0-1.rhel5          installed       
ice-c++-devel.x86_64                     3.3.0-1.rhel5          zeroc-ice       
ice-php.x86_64                           3.3.0-1.rhel5          zeroc-ice       
ice-ruby.x86_64                          3.3.0-1.rhel5          zeroc-ice       
ice-ruby-devel.x86_64                    3.3.0-1.rhel5          zeroc-ice       
-sh-3.1$ yum whatprovides /usr/bin/slice2cpp
Loading "installonlyn" plugin
Setting up repositories
Reading repository metadata in from local files



ice-c++-devel.x86_64                     3.3.0-1.rhel5          zeroc-ice       
Matched from:
/usr/bin/slice2cpp
-sh-3.1$ 

Change History (4)

comment:1 Changed 11 years ago by jmoore

  • Milestone changed from OMERO-Beta4.2 to Unscheduled

comment:2 Changed 9 years ago by jmoore

  • Milestone changed from Unscheduled to OMERO-Beta4.4

comment:3 Changed 9 years ago by jmoore

  • Remaining Time set to 0.1
  • Sprint set to 2011-11-29 (3)
  • Status changed from new to accepted

With the changes for #1274 (Ice3.4) and #1185 (slice2java version check) rather than "exec returned: 2" error global.xml, blitz/build.xml now prints:

icegen2:
     [copy] Copying 143 files to /Users/moore/GlencoeSoftware.git/git/omero.git/components/blitz/generated
     [copy] Copying 143 files to /Users/moore/GlencoeSoftware.git/git/omero.git/components/blitz/generated
     [copy] Copying 143 files to /Users/moore/GlencoeSoftware.git/git/omero.git/components/blitz/generated
     [copy] Copying 143 files to /Users/moore/GlencoeSoftware.git/git/omero.git/components/blitz/generated
     [copy] Copying 143 files to /Users/moore/GlencoeSoftware.git/git/omero.git/components/blitz/generated
     [copy] Copying 1 file to /Users/moore/GlencoeSoftware.git/git/omero.git/components/blitz/generated

BUILD FAILED
/Users/moore/GlencoeSoftware.git/git/omero.git/components/blitz/build.xml:27: The following error occurred while executing this line:
/Users/moore/GlencoeSoftware.git/git/omero.git/components/blitz/build.xml:220: Execute failed: java.io.IOException: Cannot run program "slice2java": error=2, No such file or directory
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:460)
...
	at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
	at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
Caused by: java.io.IOException: error=2, No such file or directory
	at java.lang.UNIXProcess.forkAndExec(Native Method)
	at java.lang.UNIXProcess.<init>(UNIXProcess.java:53)
	at java.lang.ProcessImpl.start(ProcessImpl.java:91)
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:453)
	... 50 more

Total time: 29 seconds

comment:4 Changed 9 years ago by jmoore

  • Remaining Time changed from 0.1 to 0
  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.93903 sec.)

We're Hiring!