Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #1708 (closed)

Opened 12 years ago

Closed 11 years ago

IDelete.deletePlate() of large plate with many rois fails with OOM

Reported by: jamoore Owned by: jamoore
Priority: blocker Milestone: OMERO-Beta4.2.1
Component: Services Version: 4.1
Keywords: n.a. Cc: jason, jburel, cxallan
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: n.a.

Description

2009-12-01 08:51:25,836 WARN  [        ome.services.util.ServiceHandler] (l.Server-6) Unknown exception thrown.

java.lang.OutOfMemoryError: Java heap space
        at org.postgresql.jdbc2.AbstractJdbc2ResultSet.next(AbstractJdbc2ResultSet.java:1863)
        at org.hibernate.loader.Loader.doQuery(Loader.java:697)
        at org.hibernate.loader.Loader.doQueryAndInitializeNonLazyCollections(Loader.java:236)
        at org.hibernate.loader.Loader.doList(Loader.java:2213)
        at org.hibernate.loader.Loader.listIgnoreQueryCache(Loader.java:2104)
        at org.hibernate.loader.Loader.list(Loader.java:2099)
        at org.hibernate.loader.hql.QueryLoader.list(QueryLoader.java:378)
        at org.hibernate.hql.ast.QueryTranslatorImpl.list(QueryTranslatorImpl.java:338)
        at org.hibernate.engine.query.HQLQueryPlan.performList(HQLQueryPlan.java:172)
        at org.hibernate.impl.SessionImpl.list(SessionImpl.java:1121)
        at org.hibernate.impl.QueryImpl.list(QueryImpl.java:79)
        at org.hibernate.impl.AbstractQueryImpl.uniqueResult(AbstractQueryImpl.java:811)
        at ome.services.query.Query.doInHibernate(Query.java:244)
        at org.springframework.orm.hibernate3.HibernateTemplate.doExecute(HibernateTemplate.java:419)
        at org.springframework.orm.hibernate3.HibernateTemplate.execute(HibernateTemplate.java:339)
        at ome.logic.QueryImpl.execute(QueryImpl.java:137)
        at ome.logic.QueryImpl.findByQuery(QueryImpl.java:333)
        at ome.services.delete.DeleteBean$7.runAsAdmin(DeleteBean.java:378)
        at ome.security.basic.BasicSecuritySystem$1.doInHibernate(BasicSecuritySystem.java:504)
        at org.springframework.orm.hibernate3.HibernateTemplate.doExecute(HibernateTemplate.java:419)
        at org.springframework.orm.hibernate3.HibernateTemplate.execute(HibernateTemplate.java:339)
        at ome.logic.QueryImpl.execute(QueryImpl.java:128)
        at ome.security.basic.BasicSecuritySystem.runAsAdmin(BasicSecuritySystem.java:493)
        at ome.services.delete.DeleteBean.getImageAndCount(DeleteBean.java:376)
        at ome.services.delete.DeleteBean.deleteImage(DeleteBean.java:146)
        at ome.services.delete.DeleteBean.deleteImages(DeleteBean.java:206)
        at ome.services.delete.DeleteBean$6.runAsAdmin(DeleteBean.java:315)
        at ome.security.basic.BasicSecuritySystem$1.doInHibernate(BasicSecuritySystem.java:504)
        at org.springframework.orm.hibernate3.HibernateTemplate.doExecute(HibernateTemplate.java:419)
        at org.springframework.orm.hibernate3.HibernateTemplate.execute(HibernateTemplate.java:339)
        at ome.logic.QueryImpl.execute(QueryImpl.java:128)
        at ome.security.basic.BasicSecuritySystem.runAsAdmin(BasicSecuritySystem.java:493)
2009-12-01 08:51:25,837 INFO  [        ome.services.util.ServiceHandler] (l.Server-6)  Excp:    java.lang.OutOfMemoryError: Java heap space
2009-12-01 08:51:25,837 ERROR [        ome.services.util.ServiceHandler] (l.Server-6) Method interface ome.api.IDelete.deletePlate invocation took 1146079

Change History (13)

comment:1 Changed 12 years ago by jrswedlow

  • Cc jason added; jrswedlow removed

comment:4 Changed 12 years ago by omero-qa

comment:5 Changed 11 years ago by jmoore

  • Sprint set to 2010-04-02 (6)
  • Type changed from Bug to Task

May be able to refactor to make this more efficient while implementing chgrp #320 / #2030

comment:6 Changed 11 years ago by jmoore

  • Remaining Time set to 0.5

comment:7 Changed 11 years ago by jmoore

  • Sprint 2010-04-02 (6) deleted

comment:8 Changed 11 years ago by jmoore

  • Milestone changed from OMERO-Beta4.2 to Unscheduled

It won't be possible to address this for 4.2.0, but it will almost certainly be necessary to handle for a patch release.

comment:9 Changed 11 years ago by jmoore

  • Milestone changed from Unscheduled to OMERO-Beta4.2.1

comment:10 Changed 11 years ago by jmoore

(In [7842]) Minor test fixes while working on delete (See #1736, #1708)

comment:11 Changed 11 years ago by jmoore

(In [7844]) DeleteBean no longer loads objects into memory (See #1708)

comment:12 Changed 11 years ago by jmoore

(In [7883]) Refactoring most DeleteI methods to use DeleteHandleI to have tests passing (See #2665, #1708)

The DeleteBean implementations were throwing NoSuchElementException during
logout. Most likely caused by the calls to session.clear() from #1708.

comment:13 Changed 11 years ago by jmoore

  • Remaining Time changed from 0.5 to 0
  • Resolution set to fixed
  • Status changed from new to closed

Deleting of a plate for which metadata import took 20 minutes took about 10 seconds as of today. No objects are loaded (only ids). Closing.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.72132 sec.)

We're Hiring!