Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

User Story #2030 (closed)

Opened 11 years ago

Closed 10 years ago

changeGroup(image)

Reported by: jamoore Owned by: jamoore
Priority: minor Milestone: Unscheduled
Component: Services Keywords: n.a.
Cc: atarkowska, jburel, cneves Story Points: n.a.
Sprint: n.a. Importance: n.a.
Total Remaining Time: 0.0d Estimated Remaining Time: n.a.

Description

A method is needed to move an image from one group to another. Some data should then be deleted, some copied, and other linkages should block the move. This is similar to IDelete, and may use the same background functionality.

Change History (17)

comment:1 Changed 11 years ago by jmoore

  • Remaining Time changed from 3 to 2

comment:2 Changed 11 years ago by jmoore

  • Status changed from new to assigned

comment:3 Changed 11 years ago by jmoore

(In [6439]) see #2030 - Initial work on changeGroup

comment:4 Changed 11 years ago by cxallan

  • Sprint changed from 2010-03-19 (5) to 2010-04-02 (6)

comment:5 Changed 11 years ago by jmoore

  • Owner jmoore deleted
  • Status changed from assigned to new

comment:6 Changed 11 years ago by jmoore

  • Owner set to jmoore

comment:7 Changed 11 years ago by jmoore

  • Milestone changed from OMERO-Beta4.2 to Unscheduled
  • Sprint 2010-04-02 (6) deleted

comment:8 Changed 10 years ago by jmoore

  • Component set to General
  • Milestone changed from Unscheduled to OMERO-Beta4.3
  • Priority set to minor
  • Sprint set to 2011-01-13 (23)

comment:9 Changed 10 years ago by jmoore

  • Component changed from General to Services
  • Type changed from Task to User Story

Turning this into a story under #320, since the estimate of 2 days -- which is low -- is too large for a single ticket.

comment:10 Changed 10 years ago by jmoore

comment:11 Changed 10 years ago by agilo

  • Status changed from new to accepted

Updated status, related task in progress

comment:12 Changed 10 years ago by jburel

  • Sprint changed from 2011-01-13 (23) to 2011-01-27 (24)

Moved from sprint 2011-01-13 (23)

comment:13 Changed 10 years ago by jmoore

  • Sprint 2011-01-27 (4) deleted

comment:14 Changed 10 years ago by jmoore

  • Milestone changed from OMERO-Beta4.3 to Unscheduled

comment:15 Changed 10 years ago by jmoore

  • Resolution set to duplicate
  • Status changed from accepted to closed

Closing as a duplicate of #3532, since the method proposed here will most likely be significantly changed in favor of something more like new delete (#2615). #3532 has also been added to #320, and the two stories here (#3843 and #3845) have also been added to #3532.

comment:16 Changed 10 years ago by agilo

  • Status changed from closed to accepted

Updated status, related task in progress

comment:17 Changed 10 years ago by jburel

  • Resolution changed from duplicate to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.84740 sec.)

We're Hiring!