Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Bug #212 (closed)

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

EventHandler should store and re-insert Stateful Events.

Reported by: jamoore Owned by: jamoore
Priority: minor Cc:
Sprint: n.a.
Total Remaining Time: n.a.

Description

Like ProxyCleanupFilter and SessionHandler, our AOP interceptors almost always need to check for instances of StatefulServiceInterface. In the case of EventHandler, the Event that is created on first use should probably be reattached to the Thread much like is done with the Session in SessionHandler.

Change History (7)

comment:1 Changed 15 years ago by jmoore

  • Keywords changed from stateful, session, aop, interceptor to stateful, session, aop, interceptor, iteration5
  • Milestone changed from Unscheduled to 3.0-M3

Rescheduling with #328

comment:2 Changed 15 years ago by jmoore

  • Keywords changed from stateful, session, aop, interceptor, iteration5 to stateful, session, aop, interceptor, iteration6

comment:3 Changed 15 years ago by jmoore

  • Keywords changed from stateful, session, aop, interceptor, iteration6 to stateful, session, aop, interceptor
  • Milestone changed from 3.0-M3 to 3.0-M4

Infrastructure is in place. Need importer in trunk for testing. Rescheduling with Rendering cleanup (milestone:3.0-M4)

comment:4 Changed 15 years ago by jmoore

r1024 adds RenderingEngine.getCurrentEventContext() to check Events.

comment:5 Changed 15 years ago by jmoore

  • Resolution set to fixed
  • Status changed from new to closed

Duplicate of #326

comment:6 Changed 15 years ago by jmoore

  • Keywords changed from stateful, session, aop, interceptor to stateful, session, aop, interceptor, iteration1

comment:7 Changed 15 years ago by jmoore

  • Keywords changed from stateful, session, aop, interceptor, iteration1 to stateful, session, aop, interceptor
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.68185 sec.)

We're Hiring!