Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

User Story #220 (closed)

Opened 14 years ago

Closed 11 years ago

Clients should be able to check their versions against the server.

Reported by: jamoore Owned by: jamoore
Priority: major Milestone: OMERO-Beta4
Component: Deployment Keywords: versions, build
Cc: jburel, bwzloranger, atarkowska, cxallan, cblackburn, carlos Story Points: n.a.
Sprint: n.a. Importance: n.a.
Total Remaining Time: n.a. Estimated Remaining Time: n.a.

Description

The server check that was available in OME-JAVA should be reproduced in Omero to allow a client to throw an exception if it connects to an invalid server.

Change History (5)

comment:1 Changed 14 years ago by jmoore

Initial Version object. Based on Chris updates in r798 / r799.

comment:2 Changed 14 years ago by jmoore

Forgot to mention r813 (r829 fixes VersionTest)

comment:3 Changed 12 years ago by jmoore

  • Milestone changed from Unscheduled to OMERO-Beta4

Requested for 4.0 release.

comment:4 Changed 11 years ago by jmoore

  • Priority changed from minor to major

Upping the priority since requires client-coding.

comment:5 Changed 11 years ago by jmoore

  • Cc jburel brain atarkowska callan cblackburn carlos added
  • Resolution set to fixed
  • Status changed from new to closed

r3353 & r3352 contain this. Use IConfig.getVersion() as guest for parsed version (4.0.0) and IConfig.getConfigValue("omero.version") for long version (Beta-4.0.0-DEV)

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.140017 sec.)

We're Hiring!