Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #2611 (closed)

Opened 11 years ago

Closed 11 years ago

BUG: rendering settings: set min max

Reported by: jburel Owned by: jburel
Priority: critical Milestone: OMERO-Beta4.2.1
Component: General Version: n.a.
Keywords: n.a. Cc:
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: 2010-08-12 (14)

Description (last modified by jburel)

Client version: 4.2
Server version: 4.2

java.lang.Exception: org.openmicroscopy.shoola.env.data.DSAccessException: Cannot access data. 
Cannot reset the rendering settings.
	at org.openmicroscopy.shoola.env.data.OMEROGateway.handleException(OMEROGateway.java:729)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.setMinMaxSettings(OMEROGateway.java:3990)
	at org.openmicroscopy.shoola.env.data.OmeroImageServiceImpl.setMinMaxSettings(OmeroImageServiceImpl.java:502)
	at org.openmicroscopy.shoola.env.data.views.calls.RenderingSettingsSaver$1.doCall(RenderingSettingsSaver.java:133)
	at org.openmicroscopy.shoola.env.data.views.BatchCall.doStep(BatchCall.java:145)
	at org.openmicroscopy.shoola.util.concur.tasks.CompositeTask.doStep(CompositeTask.java:226)
	at org.openmicroscopy.shoola.env.data.views.CompositeBatchCall.doStep(CompositeBatchCall.java:126)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.exec(ExecCommand.java:165)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.run(ExecCommand.java:274)
	at org.openmicroscopy.shoola.util.concur.tasks.AsyncProcessor$Runner.run(AsyncProcessor.java:91)
	at java.lang.Thread.run(Thread.java:619)
Caused by: omero.ApiUsageException
    serverStackTrace = "ome.conditions.ApiUsageException: unexpected end of subtree [select rdef from ome.model.display.RenderingDef as rdef left outer join fetch rdef.details.owner left outer join fetch rdef.quantization left outer join fetch rdef.model left outer join fetch rdef.waveRendering as cb left outer join fetch cb.family left outer join fetch rdef.spatialDomainEnhancement where rdef.pixels.id in () and rdef.details.owner.id = :id]; 

Change History (7)

comment:1 Changed 11 years ago by jburel

  • Description modified (diff)
  • Summary changed from BUG: to BUG: rendering settings

comment:2 Changed 11 years ago by jburel

  • Summary changed from BUG: rendering settings to BUG: rendering settings: set min max

comment:3 Changed 11 years ago by jburel

(In [7821]) Added tests for rendering settings service method (see #2611)

comment:4 Changed 11 years ago by jburel

  • Owner set to jburel
  • Sprint set to 2010-08-12 (14)
  • Status changed from new to assigned

comment:5 Changed 11 years ago by jburel

(In [7834]) merge fixes related to rendering settings bug (See #2611 and #2714)

comment:6 Changed 11 years ago by jburel

(In [7835]) fixed bugs when apply settings or resetting min max (See #2611 and #2714)

comment:7 Changed 11 years ago by jburel

  • Remaining Time set to 0
  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7836]) Turn back on tests related to resetting min max and applying rendering settings (closed #2611 and closed #2714)

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.72556 sec.)

We're Hiring!