Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

User Story #2665 (closed)

Opened 11 years ago

Closed 11 years ago

Dev can submit a delete to a queue

Reported by: jamoore Owned by:
Priority: minor Milestone: OMERO-Beta4.2.1
Component: API Keywords: n.a.
Cc: Story Points: n.a.
Sprint: n.a. Importance: n.a.
Total Remaining Time: 0.0d Estimated Remaining Time: n.a.

Description

Regardless of performance improvements to delete (#2593), some deletes will take a long time and have complicated errors to report. To facilitate this, a multi-staged (i.e. stateful) delete service needs to be developed which will allow clients to check for eventual completion. A rough example can be taken from the scripting service.

Change History (2)

comment:1 Changed 11 years ago by jmoore

(In [7883]) Refactoring most DeleteI methods to use DeleteHandleI to have tests passing (See #2665, #1708)

The DeleteBean implementations were throwing NoSuchElementException during
logout. Most likely caused by the calls to session.clear() from #1708.

comment:2 Changed 11 years ago by jmoore

  • Resolution set to fixed
  • Status changed from new to closed

Moved open tickets to cleanup story (#2593). Closing since API is available and working.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.92531 sec.)

We're Hiring!