Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #2912 (closed)

Opened 10 years ago

Closed 10 years ago

Bug: Table service needs to pass client_uuid

Reported by: jamoore Owned by: jamoore
Priority: minor Milestone: OMERO-Beta4.2.1
Component: Services Version: n.a.
Keywords: n.a. Cc:
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: 2010-09-30 (17)

Description

From #2908:

        Id:83e71fac-6cc4-40d0-9258-fcedb23f7dd4/c0:a8:b2:20:-71c351f2:12b3e8f0431:-7ff0omero.api.RawFileStore
        Op:close
        Ctx:{omero.group=0}
        at ome.services.blitz.fire.SessionManagerI.getServiceFactoryIdentity(SessionManagerI.java:404)
        at ome.services.blitz.fire.SessionManagerI.onApplicationEvent(SessionManagerI.java:275)
        at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:97)
        at ome.services.messages.GlobalMulticaster.multicastEvent(GlobalMulticaster.java:55)
        at ome.system.OmeroContext.publishEvent(OmeroContext.java:327)
        at ome.system.OmeroContext.publishMessage(OmeroContext.java:341)
        at ome.services.blitz.impl.AbstractAmdServant.close_async(AbstractAmdServant.java:234)
        at omero.api._RawFileStoreTie.close_async(_RawFileStoreTie.java:120)
        at omero.api._StatefulServiceInterfaceDisp.___close(_StatefulServiceInterfaceDisp.java:142)
        at omero.api._RawFileStoreDisp.__dispatch(_RawFileStoreDisp.java:327)
        at IceInternal.Incoming.invoke(Incoming.java:159)
        at Ice.ConnectionI.invokeAll(ConnectionI.java:2037)
        at Ice.ConnectionI.message(ConnectionI.java:972)
        at IceInternal.ThreadPool.run(ThreadPool.java:577)
        at IceInternal.ThreadPool.access$100(ThreadPool.java:12)
        at IceInternal.ThreadPool$EventHandlerThread.run(ThreadPool.java:971)
Caused by: omero.ApiUsageException
    serverStackTrace = (null)
    serverExceptionClass = (null)
    message = "No omero.client.uuid key provided in context."
        at ome.services.blitz.impl.ServiceFactoryI.clientId(ServiceFactoryI.java:1054)
        at ome.services.blitz.fire.SessionManagerI.getServiceFactoryIdentity(SessionManagerI.java:401)
        ... 15 more

Change History (7)

comment:1 Changed 10 years ago by jmoore

  • Status changed from new to assigned

comment:2 Changed 10 years ago by jmoore

  • Remaining Time set to 0.25

comment:3 Changed 10 years ago by jburel

  • Sprint changed from 2010-09-09 (16) to 2010-09-30 (17)

comment:4 Changed 10 years ago by jmoore

  • Owner jmoore deleted
  • Status changed from assigned to new

comment:5 Changed 10 years ago by jmoore

  • Owner set to jmoore

comment:6 Changed 10 years ago by jmoore

  • Status changed from new to assigned

comment:7 Changed 10 years ago by jmoore

  • Remaining Time changed from 0.25 to 0
  • Resolution set to fixed
  • Status changed from assigned to closed

(In [8257]) OmeroTables: Setting client_uuid for passed ServiceFactoryPrx (Fix #2912)

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.202495 sec.)

We're Hiring!