Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #3165 (closed)

Opened 9 years ago

Closed 8 years ago

Bug: NoneType exception on loading image

Reported by: jamoore Owned by:
Priority: minor Milestone: Unscheduled
Component: Web Version: n.a.
Keywords: n.a. Cc: cneves, atarkowska
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

Environment:

Request Method: GET
Request URL: http://localhost:8888/webclient/metadata_details/image/2357/
Django Version: 1.1.1
Python Version: 2.6.6
Installed Applications:
['django.contrib.admin',
 'django.contrib.markup',
 'django.contrib.auth',
 'django.contrib.contenttypes',
 'django.contrib.sessions',
 'django.contrib.sites',
 'omeroweb.feedback',
 'omeroweb.webadmin',
 'omeroweb.webclient',
 'omeroweb.webgateway',
 'omeroweb.webtest',
 'omeroweb.webemdb',
 'omeroweb.webmobile']
Installed Middleware:
('django.middleware.common.CommonMiddleware',
 'django.contrib.sessions.middleware.SessionMiddleware',
 'django.middleware.doc.XViewMiddleware')


Traceback:
File "/Users/moore/GlencoeSoftware.git/git/omero.git/dist/lib/python/django/core/handlers/base.py" in get_response
  92.                 response = callback(request, *callback_args, **callback_kwargs)
File "/Users/moore/GlencoeSoftware.git/git/omero.git/dist/lib/python/omeroweb/webclient/views.py" in wrapped
  185.         return f(request, *args, **kwargs)
File "/Users/moore/GlencoeSoftware.git/git/omero.git/dist/lib/python/omeroweb/webclient/views.py" in load_metadata_details
  875.         for ch in manager.channel_metadata:

Exception Type: TypeError at /webclient/metadata_details/image/2357/
Exception Value: 'NoneType' object is not iterable

This may be related to global data since I'm running fastcgi as "threaded".

Change History (3)

comment:1 Changed 9 years ago by atarkowska

Could you please send me the file is causing that problem. I cannot reproduce it.

comment:2 Changed 9 years ago by jmoore

Sorry, it was 4 months ago. This database is gone. I'd guess as long as you check that Nones are handled in omeroweb.webclient.views.load_metadata_details then it should be ok.

comment:3 Changed 8 years ago by wmoore

  • Resolution set to fixed
  • Status changed from new to closed

Failure to load channel metadata appears to be handled now:

    def channelMetadata(self):
        self.channel_metadata = None
        try:
            if self.image is not None:
                self.channel_metadata = self.image.getChannels()
            elif self.well is not None:
                self.channel_metadata = self.well.getWellSample().image().getChannels()
        except:
            pass
        
        if self.channel_metadata is None:
            self.channel_metadata = list()
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.197181 sec.)

We're Hiring!