Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #4088 (closed)

Opened 12 years ago

Closed 4 years ago

LegacyQTWriter cannot save using Motion JPEG-B codec

Reported by: curtis Owned by: mlinkert
Priority: trivial Milestone: Unscheduled
Component: Bio-Formats Version: OMERO-5.2.0
Keywords: export, LegacyQTWriter Cc:
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description (last modified by mlinkert)

When attempting to save using the Motion JPEG-B codec, there is a failure within the QuickTime? for Java code claiming that the codec is not present, even though QTJava reports it as available elsewhere:

curtis@monk:~/java$ java MakeQT ~/data/ome-tiff/curtis/time-series.ome.tif out.mov
loci.formats.ReflectException: Cannot instantiate object
        at loci.formats.ReflectedUniverse.exec(ReflectedUniverse.java:239)
        at loci.formats.out.LegacyQTWriter.saveImage(LegacyQTWriter.java:175)
        at loci.formats.out.QTWriter.saveImage(QTWriter.java:227)
        at MakeQT.main(MakeQT.java:19)
Caused by: java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
        at loci.formats.ReflectedUniverse.exec(ReflectedUniverse.java:233)
        ... 3 more
Caused by: quicktime.std.StdQTException[QTJava:7.2.0g],-8961=noCodecErr,QT.vers:7208000
        at quicktime.std.StdQTException.checkError(StdQTException.java:38)
        at quicktime.std.image.CSequence.begin(CSequence.java:137)
        at quicktime.std.image.CSequence.<init>(CSequence.java:81)
        ... 8 more

For now, we can leave the option to save as Motion JPEG-B commented out, since such support is not a high priority.

Change History (3)

comment:1 Changed 9 years ago by jmoore

imported from bio-formats:#169

comment:2 Changed 7 years ago by mlinkert

  • Description modified (diff)
  • Keywords export added

comment:3 Changed 4 years ago by mlinkert

  • Keywords LegacyQTWriter added
  • Resolution set to wontfix
  • Status changed from new to closed
  • Version set to OMERO-5.2.0

Given that QuickTime? for Java is usable on a minority of systems, I don't think this is worth our trouble any longer.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.120431 sec.)

We're Hiring!