Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #4376 (closed)

Opened 9 years ago

Closed 8 years ago

Python scripts to use blitz gateway

Reported by: wmoore Owned by: wmoore
Priority: major Milestone: OMERO-Beta4.3
Component: OmeroPy Version: n.a.
Keywords: n.a. Cc: cneves
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: 2011-05-19 (12)

Description (last modified by wmoore)

If we can use the blitz gateway in the scripting service, then all Python API users can start in the same place - docs, API learning etc and this functionality is available to Script writers.

Need to be able to create a blitz wrapper from the 'client' object provided by the scripting service #4237.

Once this is done, we can start converting some of the scripts over to blitz gateway.

  • Examples (edit description etc)
  • Util scripts
  • At least some figure-scripts. For ones we don't have time for, maybe add comment to script in case anyone tries to copy!

Change History (13)

comment:1 Changed 9 years ago by wmoore

  • Summary changed from Scripting service to use blitz gateway to Python scripts to use blitz gateway

comment:2 Changed 9 years ago by wmoore

  • Remaining Time changed from 1 to 0
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4237

comment:3 Changed 9 years ago by wmoore

  • Description modified (diff)
  • Remaining Time changed from 0 to 2
  • Resolution duplicate deleted
  • Status changed from closed to reopened

When

comment:4 Changed 8 years ago by wmoore

  • Sprint changed from 2011-02-24 (6) to 2011-05-05 (11)

Going to start writing stand-alone versions of some scripts, using the blitz gateway. These can be more quickly converted to Scripting service scripts when blitz gateway is accessible there.

comment:5 Changed 8 years ago by Will Moore <will@…>

(In [ffcae27215598176cf5b2b6c4470c97c66cfd024/ome.git] on branch develop) Fix tiny bug in Batch_Image_Export.py script. See #4376

comment:6 Changed 8 years ago by Will Moore <will@…>

(In [f00fdaee9386e4d0d9b4831f36f50457d73f3676/ome.git] on branch develop) Using blitz gateway for Batch_Image_Export.py script. See #4376

comment:7 Changed 8 years ago by Will Moore <will@…>

(In [804a8b226a104a2f5d39e991d09dcf35efd53b60/ome.git] on branch develop) Batch_Image_Export.py uses BlitzGateway?(client_obj=client). See #4237, #4376

comment:8 Changed 8 years ago by Will Moore <will@…>

(In [6d30dd70a1e63e19b6bbc6c164df2bc21f29f6e2/ome.git] on branch develop) Add fig-legend (description) to Batch_Image_Export.py & remove unused code. See #4376

comment:9 Changed 8 years ago by jburel

  • Sprint changed from 2011-05-05 (11) to 2011-05-19 (12)

Moved from sprint 2011-05-05 (11)

comment:10 Changed 8 years ago by Will Moore <will@…>

(In [1198fe30bedfc6ea586308607f53c84ee4dab012/ome.git] on branch develop) Ongoing work moving scripts to use Blitz Gateway. See #4376

comment:11 Changed 8 years ago by Will Moore <will@…>

(In [b074a3162301e99215d65bf08650593e21e81ab2/ome.git] on branch develop) Fixing small bugs and parameters in Channel_Offsets.py. See #4376

comment:12 Changed 8 years ago by Will Moore <will@…>

(In [8210709b2cfbaecab4711c2af4d448159cc3557a/ome.git] on branch develop) Images_From_ROIs script uses Blitz Gateway. See #4376

comment:13 Changed 8 years ago by wmoore

  • Remaining Time changed from 2 to 0
  • Resolution set to fixed
  • Status changed from reopened to closed

Various scripts now use the Blitz Gateway - Closing this ticket for 4.3.
These have not been moved yet:

  • Movie_Figure.py
  • Movie_ROI_Figure.py
  • ROI_Split_Figure.py
  • Combine_Images.py
  • Split_View_Figure.py is not fully converted (rendering etc) #5192.
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.95486 sec.)

We're Hiring!